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INSTALLATION 

Congratulations on your purchase of AtariWorks™ sohware--the complete 
package for home or office automation! 

Installing your software couldn't be simpler--the first thing is 10 make a 
copy of your AtariWorks Installation Disk. Then put the original in a safe place, 
away from dust, moisture, or magnetic fields, and use the copy to proceed. 

1. Boot your system, or return to the desktop. 

2. Place the copy you made of the AtariWorks Installation Disk in your 
A: drive. Double-click on the A: drive icon. 

3. Double-click on INSTALl.PRG and follow the screen directions. The 
prompts will tell you when installation is complete. 

That's all there is to it. In your C: drive, you'll find a file titled WORKS.PRG. 
Double-click on it and away you go! 

Be sure 10 read the resl of this manual so you can gel the most from your 
new software. 

This manual was written on an Atari Falcon030'''' computer using the 
AtariWorks Word Processor. It was edited, produced and illustrated using 
PageStream' desktop publishing software on an Atari TT030T

'" computer. 

'Copyright 1988, 1991 Soh-Logik Publishing. 
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WELCOME 

Welcome to AtariWorks'" -- all the office tools you may ever need to 
automate your worle 

• A Word Processor with drawing and mall merge. 
• A Database with reporting. 
• A Spreadsheet with charting. 
• --And a way to use them alilogether. 

The Word Processor 

Click on the Word Processor to write and edit text. CUI and paste 
electronically to polish your prose. Change the margins and walch AtariWorks 
make everything fit. Change words quickly and easily by using search and 
replace functions. Format your document using real tonts with a few clicks of the 
mouse. Draw lines, circles, and boxes for extra flair. Paste in graphics and 
charts to illustrate your text. With Marginalia, you can place notes in your 
document for viewing within AtariWorks. Audio Annotator (available on Atari 
computers equipped with DMA sound) allows you to leave voice or sounds as 
marginal notes in your text files. 

The Database 

~ ones you don't need. Sort lists to organize your reports. Have AtariWorks 
II Qmll Click on Ihe Database to file informalion. Add new records and remove the 

~ quickly search for the information you need. Prepare numerous reports from 
one set of information--with each report providing just the facts you need. 

The Spreadsheet 

• 

Click on the Spreadsheet to organize and calculate numbers. Set up 

_ s elaborate formulas and let AtariWorks get the answers for you. Change your 
r:iI assumptions, change your numbers, and see what you get. Choose from a 
IaIIJ multitude of built-in calculations to make your work easier. Use the 

spreadsheet's charting capability to see what your spreadsheet numbers look 
like in charts. Change a number in a spreadsheet document and instantly see 
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how it affects your charts. Try different comparisons using the same document. 
Spot trends at a glance, or see who's got the biggest piece of the pie. 

Using the Tools Together 

With AtariWorks, you can not only work with several tools at once, you can 
also move information from one tool to another. For example, you can write a 
letter with the Word Processor, check an address in the Database, project future 
sales with the Spreadsheet, and see how your projections look with the 
Spreadsheet's charting capability. Then you can copy the chart into your letter 
for a finished , professional effect. 

AtariWorks takes full advantage of Atari's FSM/SpeedoGDOSllO 

component to provide you state-of-the-art, true scalable font technology . The 
Word Processor and the Spreadsheet provide true What You See Is What You 
Get screen displays of your documents. Thus, when you print a document from 
the Word Processor or Spreadsheet, you are assured of eye-pleasing results. 

About this Manual 

Read this manual when you 're ready to start using AtariWorks. This 
manual is divided into six sections. The next section, Common Tasks, guides 
you through tasks that you'll periorm every time you use AtariWorks. These 
include activities such as creating , saving and printing documents. The next 
three sections explain the individual AtariWorks tools: the Word Processor, 
the Spreadsheet, and the Database. The last section, Using the Tools 
Together, explains how to integrate information from all the different tools. 
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COMMON TASKS 

OPENING A FILE OR CREATING A NEW DOCUMENT 

When you start AtariWorks, you'll see the item selector box containing 
icons for each of AtariWorks tools. Word Processing is the default choice: 

Use this box to open files from the disk or to creale new documents in one of 
the AtariWorks tools. You can have up to seven open documents on your 
desktop at once, depending on how many windows are supported and the 
amount of available memory. 

Creating a New File 

1. If you are already in AtariWorks, click on New from the Fi Ie menu to 
display the item selector box (or press (ControIJ -N). 

2. Click the icon for the type of document you want to create. 

3. Click the New bunon. A new document window opens on the desktop. 
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Opening a File 

1. If you are already in AlariWorks, click on Open from the File menu to 
display the item selector box (or press [Contrall-O). 

2. Select the appropriate tool icon. 

3. Click the Open button. AtariWorks displays a file selector box listing all 
relevant files and folders on the current disk. 

4. Select the name of file you want to open. 

5. Click the OK button or double click the file name. AlariWorks opens the file 
in a new document window on the desktop. 

Importing a File 

1. Click on Import File ... under the File menu (or press [ShiftHControlj-O). 

2. A dialog box appears with options regarding the AtariWorks tool into which 
you want the file to be imported and the format of the file requested. 

3. Make your choices and click on OK. 

4. The Item Selector screen appears. Select the name of the file you want to 
import. 

5. Click the OK button. AtariWorks reads the selected file and opens the 
proper document window, with the imported document. 

SAVING DOCUMENTS 

To save a document for the first time: 

,. Choose Save As .•• from the Fite Menu (or press (Shift]-[Control]-S). 
AtariWorks displays the Save As ... dialog box, which is ready to accept 
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the name you type in. 

2. Type a name for the document. 

3. To save on another directory or drive, give the full pathname. 

4. Click the OK button or press the [Return] key. Click the Cancel 
button if you decide not to save. 

Note that AtariWorks saves its various documents with the following 
unique extensions: 

.STW Word Processor file 

.STD Database file 

.STS Spreadsheet file 

Note: If you wish to use a different extension after the S-Ietter filename, type a 
period (.), then a three-letter extension of your own choice. 

To save changes to a document: 

If you're working with a document that you've already saved, you can save 
changes as you work (and irs a very good idea)! Choose Save from the File 
menu or press [ControIJ-S. AtariWorks saves the changes, and you can 
continue working with the document. 

To save a document with a diHerenl name: 

When you want to save both an original file and a new file wilh the 
changes you've made to iI, you can save the document with a different name: 

1. Choose Save As ... from the File menu or press [Shift]-[Control]-S. 
AtariWorks displays the Save As dialog box, which is ready to accept the 
name you type in. 

2. Type a new name for the document. 

3. Click the OK button or press the [Return) key. If another file with the 
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name you've typed is already on the disk, AtariWorks asks if you want to 
overwrite it. You can go ahead or cancel the command. Either way, the 
original fi le remains unchanged. 

Exporting a F·ile 

To export a file to another program, you must save it as an ASCII text file. 
This means that only the data, and not the formatting information (fonts, 
margins, indents, etc.), is saved. Choose Export File ... from the File menu. 

CLOSING A DOCUMENT 

When you want 10 remove a document from the desktop, you close it. 
Choose Close from the File menu, or press [Controlj·W, or click the closer box 
in the upper·left corner of the window. If you've made any changes to the 
document, AlariWorks asks if you want to save the changes. You can Save with 
changes, Abandon your changes, or Cancel the command. Cancelling the 
command leaves the document in the window, while the other commands close 
the window. 

VIEWING DOCUMENTS IN WINDOWS 

The Window menu contains options for handling the way things appear in 
document windows. In the Word Processor, the Window menu also includes 
toggle options for showing or hiding the Ruler and the Tool Bar. 

Full/Small Window 

This is a toggle option for using the whole screen or just part of it. 

Preferences ... 

Default Font 

Choices in this box include setting the default typestyle and size, plus other 
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aspects of text style. To see a menu of the choices available, click inside the 
applicable box. 

ASCII Export 

This specifies whether an exported ASCII file will have a hard return after 
each line (the default setting) or only after the end of a paragraph. 

Spelling Checkerrrhesaurus SeHings 

Click on this box and a dialog box appears in which you can change the 
location(s) for the Spelling Checker and the Dictionaries. You might want to do 
this if you have several different user dictionaries, for example, or if space on a 
particular drive becomes a problem. 

Short Date Format 

Click on this box to see the various style options available. Click on 
another to change the default. 

Activate Document 

If you have more than one document open on the desktop, choosing this 
option will present a list of the documents open. Click on Ihe one you want 
activated; it will come to the top. 

HEADERS AND FOOTERS 

When you want to print information at the top or bottom of every page, use 
a header or fooler. The same information will appear on every page, except that 
page numbers will appear sequentially. Headers and footers are set up using 
the same dialog box. The Define Header/Footer dialog box is accessed by 
clicking on Ihe Header/Footer .•. option under the File menu. 

1. The first option in the dialog box allows you to choose whether you 
want to define a header or footer. Click to make your choice. 
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2. Next choose a font for the header or footer. Click on the right-hand 
button of the bar and a list of available fonts will drop down. Click to 
choose. Then specify a size, which can be typed in on the blanks 
provided. Although there are three blanks (the range of sizes is from 1 to 
144 points), you can type in single and double digit numbers. 

3. The next option in the dialog box is Style, where icons are provided 
to set your text as normal, bold, italics, underlined, outline or in any 
combination (except normal) you may choose. 

4. In the Distance from the Top box, type in the amount of space from 
the top of the page to the base of the header you want. In the Distance 
from the Bottom box, type in the amount of space from the bottom of the 
page to the base of the footer you want. 

5. On the last line of the dialog box, type in the text you wish to be 
displayed as the header or footer. To indicate information such as the 
current date, page number, or document name, AtariWorks provides a set 
of formatting commands, which can be entered on this line. These are 
described below. 

To use special formattingsin the Headers/Footers 

You can use special characters to automatically print cenain information in 
your header and footer. The "#" symbol and a lener is the special character set 
used. The following lists different commands you can use. Either upper- or 
lower-case letters can be used. 

#P Page Number 
#0 Current date, as set in your computer 
#T Current time, as set in your computer 
#F The document name (the extension in the filename is 

omined) 

You can also specify where the information is to appear. Use # followed by 
L, R, C for information to appear flush left, flush right, or centered. The string 
following such control characters will be printed according to the control 
character: 
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#L The following string is printed flush left. 
#R The following string is printed flush right. 
#C The following string is printed centered. 

You can use these control characters as many times as you want in your 
headerlfooter strings. You can also combine these special characters with 
regular text. 

Example: You type #L#F AtariWorks Manual #CPage 5-#P #ROraft #0 in 
your footer box. If the document name is SECTlON5.STW and you print it on 
January 7th, the footer on the third page reads: 

SECTION5 AtariWorks Manual Page 5-3 Draft January 7, 1993 

PRINTING A DOCUMENT 

You can print documents from all the AtariWorks tools. Although you adjust 
the format for each tool differently, you print them all the same way using the 
File menu. 

Setting Up Your Page 

Before you print a document, choose the Page Setup ... command from the 
File menu (or press [Shift)-[Control)-P) to specify exactly how you want it to be 
printed. The Page Setup ... command leis you specify paper size, headers, 
footers, and margins. 

To change page specifications: 

1. Choose Page Setup ... from the File menu. The Page Setup dialog 
box appears. 

2. Make changes in the dialog box as you want. 

3. Click the OK button or press the [Return] key. AtariWarks stores your 
specifications with the document, so you only have to change them once. 
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To Use Custom Paper 

With AtariWorks, you can print on any size paper that fits into your printer. 
To use a paper size other than those offered, click the custom size option in the 
Page Setup ... dialog box. For example, click Custom Size if you are printing 
maiting labels. Then you can specify the exact dimensions of your paper in the 
Paper Width and Paper Height boxes. 

To Use the Printer Paper Size Supported by the Printer 

Sometimes you may like to print your document on the paper supported by 
the printer driver. In order to check what size of paper your printer driver 
supports, click on Set Size to Current Printer. The current printer paper width 
and height will appear in the paper width and height boxes. 

Sending Your Document to the Printer 

When you're satisfied with your page setup, you are ready to print your 
document. 

1. Choose Print •.• from the File menu or press [ControIJ-P. 1I necessary, 
a Select Printer dialog box appears. Choose the appropriate printer and 
click the OK button. The Print dialog box will appear. 

2. Make any desired changes to the print specifications. (Clear entries 
with the [Esc] key.) 

3. Click the OK button to accept your specifications. AtariWorks begins 
to print your document. 

To Cancel Printing In Progress 

You can cancel the print command at the end 01 any printer page. Press 
the [ControIJ-C keys. AtariWorks may continue to print briefly until the printer's 
memory is empty. After printing stops, AtariWorks returns you to the document 
window. 
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TO QUIT ATARIWORKS 

1. Choose Quit from the File menu. If you've made changes to your 
document since the last lime you saved it, AtariWorks asks whether or not 
you want to save the changes. 

2. For each document, click Save to save your changes or Abandon if 
you'd rather not. Click Cancel to go back. 
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THE WORD PROCESSOR 

You can write jusl about anything with AtariWorks Word Processor: letters, 
memos, reports, press releases, advertising copy, or even a novel. AtariWorks 
also lets you use different fonts and graphics to help convey your written 
message. Furthermore, Marginalia allows you to place notes in your file that can 
be called up by someone else using AtariWorks. Owners of Atari computers 
with DMA sound (STe, TT, and Falcon series) can call up audio notes 
generated using the Audio Annotation feature. 

This Chapter of the manual shows you what you need to know about 
writing with the Word Processor: 

• Writing and Editing shows what a word processor document looks like, 
how to enter and edit text, and how to change the tont, the type style, and the 
type size. 

• Formatting a Document explains ways to arrange your writing on the 
page, and how to draw lines and shapes within a document. 

• Marginalia and Audio Annotation explains how to include private notes 
in your document. These notes can be written or, in some cases, they can be 
audio. 

• illustrating a Document explains how to draw lines and shapes in your 
word processing document and how to handle these illustrations as separate 
graphic files (GEM Metaliles). 

If you want to use the Word Processor with other tools-·for example, to 
create form letters or mailing labels with Database information , or to add charts 
from the Spreadsheet, see Using the Tools Together (Chapter 6) . 
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WRITING AND EDITING 

When you write and edit with the Word Processor, you don't have to retype 
whole pages to make a change. You just insert, delete, or correct your text , and 
AtariWorks automatically adjusts the lines within paragraphs and repaginates. 
After you finish editing with the Word Processor, you have a finished product, 
ready to print. 

This section shows you how to: 

• Recognize the parts of a word processor document, and create a new 
document. 

• Enter text. 

• Undo an editing mistake. 

• Select text and pictures. 

• Delete text and pictures. 

• Cut. copy, and paste. 

• Find and replace text. 

• Change fonts, type styles and type sizes. 

To Create a New Word Processor Document or to Open an 
Existing File 

When you start AtariWorks or choose New/Open (or press [ControIJ-N or 
[Control[·O) from the File menu, the Open dialog box appears. 

1. Click on the Word Processor icon. 

2. Click on the New button. AtariWorks opens a new word processor 
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document. You can begin typing . 

··or·· 

1. Click on the Word Processor icon. 

2. Click on the Open button. The file selector box appears. 

3. Select an existing file name to open. 

4. Click on the OK button . AtariWorks will open the chosen Word 
Processor document. You can start writing and editing. 

Entering Text 

Text is made up of charac1ers·· letters, numbers, symbols , and spaces are 
all characters to the Word Processor. The Word Processor stores the text in 
your computer's memory until you close the document or name and save the 
file, in which case it is also stored on disk. 

The Word Processor takes care of fitting your words into lines as you type. 
When you reach the end of a line, any word that doesn't fit within the right 
indent marker automatically moves to the next line. This is called wordwrap. 
Wordwrap lets you type complete paragraphs without pressing the [Return] key. 
If you insert text in the middle of a paragraph, wordwrap automatically expands 
the lines; if you delete text in the middte of a paragraph, wordwrap closes up the 
empty space. 

The Word Processor {Return] key actually types an invisible character, 
called a Return character. This character signals the end of a paragraph for 
wordwrap. You should press the Return key only at the end of a paragraph. 
Wordwrap makes a neat paragraph of anything between return characters. 

If you want to control the ends of lines yourself--as in poetry or lists, for 
example--you can press the [Return) key at the end of each line. A single line 
with a return character at the end is just a short paragraph to the Word 
Processor. Wordwrap won" affect these lines. 
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You can also use the [Return] key to insert blank lines into your document: 

1. Position the pointer and click (or use the cursor keys) to place the 
cursor (the flashing vertical line) where you want to insert the blank line. 

2. Press the [Return) key once if you're at the beginning of a paragraph, 
or twice if you're somewhere in the middle. 

You can insert text anywhere in a document by moving the insertion point: 

1. Position the cursor where you want to insert the text. 

2. Begin typing. Your text pushes the insertion point and any following 
text to the right. 

As you continue to type text into your word processor document, you will 
notice that a horizontal line appears on the left side of your Word Processor 
Window. This is a page break indicator. For more information about page 
breaks, see Formatting an Entire Document later in this chapter. 

When the page break has scrolled up on the screen so that it is the first 
line in the window, the page number box on the left side of the Tool Bar shows 
the page number corresponding to the first line of text in the window. 

Undoing a Mistake 

In many cases, choosing the Undo command from File menu (or pressing 
the (Undo) key) cancels the last action you've taken. You can undo most Word 
Processor commands from the Edit, Format, and Style menus. If you save 
your text otten (we suggest every ten minutes or so), you may prevent major 
mistakes that you cannot undo. Saving a document stores a copy of it on your 
disk. For more information, see Saving Documents in Chapter 2. 

One other kind of mistake can be easily fixed using the keyboard 
combination of the (Control] key and the letter T. Sometimes you may find that 
you have switched around letters in a word . Instead of form, for example, you 
may have typed from. To fix this transposition of letters: 
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1. Place your insertion point after the transposed characters (after ro in 
the example above). 

2. Press [Controlj-T (T for transpose). The letters will switch places and 
they will look like or in the example above. 

This function is strictly a keyboard function and cannot be accessed by any of 
the menus. 

Selecting Text and Pictures 

When you want to do something with a picture or a block of text--remove it, 
for example--you must first select it. AtariWorks shows a selection by 
;mmmiDlm't--turning black letters or pictures on a white background into white 
on black .. 

You can select a character, a word, a line, a sentence, a paragraph, any 
size block of text, or a picture. In most cases, you must select text and pictures 
separately. However, if, while you are selecting a block of text, you also select a 
complete picture, then both the text and picture will be selected. 

To Select by Dragging 

Position the pointer on one edge of what you want to select, and press the 
left mouse button. Drag to select as much as you want, then release the button. 
If your mouse pointer goes beyond the window boundaries AtariWorks will 
automatically scrolilhe document in the direction and select the text. 

Selecting a Single Word 

To select a single word quickly, move the insertion point to anywhere 
inside the word and double-click. 

Selecting lines of Text 

Position the cursor anywhere in the line desired. Press [Shift] and double­
click the left mouse button. The line is selected. If you want to select more than 
one line, drag the mouse. AtariWorks selects full lines as you drag. 
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Selecting Paragraphs 

Position the cursor anywhere in the paragraph desired. Press (Control) and 
double-click the left mouse button. The paragraph is selected. If you want to 
select more than one paragraph, drag the mouse. AtariWorks selects full 
paragraphs as you drag. 

To Select a Picture 

A picture can be a line or figure you draw with the Word Processor, or a 
chart from the AtariWorks Spreadsheet, or a GEM Metafile you have imported 
into your document. When you select a picture , a highlighted rectangle encloses 
the picture. 

1. Position the text cursor over the picture you want to select (it should 
overlap the text cursor). 

2. Choose Select Picture from the Edit menu (or press [ControIJ-Z). 

To Select an Entire Document 

You can also select an entire document without dragging the mouse. You 
may want to do this to change the font or format all the way through. Choose 
Select Ali from the Edit menu (or pr~ss (Controll-A). AtariWorks selects all the 
text and pictures in the document. 

Deleting Text 

You can delete single characters with the [Delete1 or [Backspace) keys, or 
you can select any amount of text and delete it with the Cut or Clear commands 
from the Edit menu. You can undo any of these actions with the Undo 
command from the Edit menu. 

To defete backwards: 

1. Position the insertion point to the right of the character(s) you want to 
delete. 
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2. Press the (Backspace] key. AtariWorks removes the character from 
your document. 

To delete forward: 

1. Position the insertion point to the left of the character(s) you want to 
delete. 

2. Press the (Delete) key. AtariWorks removes the character from your 
document. 

To defete a blank line: 

You can delete a blank line to close up the space between two 
paragraphs. Position the insertion point at the left edge of the first line of 
the paragraph you want to move back. You can press the (Backspace] key 
twice to join the two paragraphs into one. Or you can use the [Delete) key 
with the insertion point where the blank line is. 

To delete a selection: 

1. Select whatever you want to delete. 

2. Press the (Backspace] or (Delete] key or choose Clear Irom the Edit 
menu. AtariWorks removes the selection from your document 
permanently. 

--or--
Choose Cut from the Edit menu or press (Cantrall -X. AtariWorks removes 
your selection from the document and puts it on the Clipboard. This leads 
us to discuss other powerful editing functions. 

Cutting, Copying and Pasting 

As mentioned, the Cut command moves a selection from its current 
location to the Clipboard. The Copy command (or [Control]-C) leaves the 
selection where it is, but puts a copy on the Clipboard. The Paste command (or 
[Control)-V) copies the contents of the Clipboard to a new location. 
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The Clipboard is a special place on your computer's hard disk that holds 
information to be copied or transferred between documents or to different 
places in the same document. Each time you cut or copy information, the new 
selection replaces any old one on the Clipboard. The folder C:\CLlPBRO\ holds 
the information contained in the clipboard. 

To cut a selection: 

1. Select the information you want to cut. 

2. Choose Cut from the Edit menu (or press [Cantrall-X). The selection 
remains on the Clipboard until you cut or copy another selection. 

To copy a selection: 

1. Select the information you want to copy. 

2. Choose Copy from the Edit menu (or press [ControIJ-C) . The copied 
selection remains on the Clipboard until you cut or copy another selection. 

Once you have cut or copied a selection to the Clipboard, you can paste it 
to as many different places as you want. 

Each time you cut or copy information, the new selection replaces the old 
one on the Clipboard. So if you want to paste a selection that you've cut or 
copied, you must do so before cutting or copying anything else. 

To paste a selection: 

1. Move the insertion point to where you want to paste the Clipboard 
text. 

2. Choose Paste lrom the Edit menu (or press IControIJ-V). 

You can repeat these steps as often as you wish. You can also cut and 
paste between documents as well as within a document. Text put on the 
Clipboard remains there as you close one document and open another. 
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Note: AtariWorks supports intelligent cut and paste. If you select a word by 
double clicking and choose Cut or Clear or use [Backspace] or (Delete]. 
AtariWorks will remove any extra blank space along with the deleted word. Also. 
while pasting text. it pads extra blank spaces around the text being pasted. if 
needed. 

Finding Text 

If you're looking for a particular word or phrase, or want to move quickly to 
specilic text within a document, the Word Processor can find it for you. With the 
Find command, AtariWorks finds all occurrences of the text you specify. This 
can include instances where the text is embedded in other text. For example, if 
you tell AtariWorks to find able, it will highlight those four characters if it Hnds 
the word valuable. If you want AtariWorks to ignore such occurrences, click the 
Match Whole Words Only option. Also, AtariWorks ignores capitalization in the 
text you specify to be found. If you want to find only those occurrences of text 
where the capitalization is exactly as you type it in the text box, click the Check 
Case option. 

If you have graphic illustrations in your document, it is very time­
consuming when AtariWorks scrolls the document to show you what it has 
found. To make your search faster, select the Hide GEM Metafile option. 

To find text: 

1. Choose Find from the Search menu (or press (Control]-F). 
AtariWorks brings up a dialog box that asks you what you want to find. 

2. Type the characters you want to find. 

3. Select any of the options you want. 

4. Click the Find Next bunon. AtariWorks highlights the first occurrence 
of the string of characters if it is in the document. 

5. If you want AtariWorks to look for another occurrence of the text you 
specified, click the Find Next button again. 
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To cancel a search in progress: 

1. Press [ControIJ-C. AtariWorks stops the search wherever it is at that 
point. 

If, while you are typing or reviewing your document, you come across a 
word that is misspelled, you can select the word, and then choose Find. The 
selected word will appear in the Find box, so you don't need to type it. You can 
then find any other occurrences of the misspelled word. (Also see Spelling 
CheckerlThesaurus later in this chapter. ) 

Replacing Text 

You can replace text in a single location by selecting it and then typing 
over it. You can also have the Word Processor find a word or phrase for you in 
a document. Then, you can choose to replace every occurrence of it at once, or 
decide each case individually. 

For more extensive search and replace actions, use the Replace 
command from the search menu. The Replace command finds and replaces 
text. You can replace all occurrences of the text, or you can go through and 
selectively replace each occurrence. one at a time. As with the Find command, 
you can click options to specify whether AtariWorks searches for whole words 
only. for text with matching uppercasa and lowercase letters, or to hide GEM 
Metafiles, which speeds searching through documents that contain graphics. 
You can also select the text you want to replace before choosing the Replace 
command. then have it automatically appear in the Find What box. 

Sometimes a word or phrase occurs often. but you want to replace it in 
only one place. Use the Find Next button to find successive occurrences of the 
specified text until you see the one you want to replace. Or use the same button 
to verify each occurrence of the specified text before you replace it. After each 
replacement, you can look for another occurrence. 

There are several other buttons in the Replace dialog box. These tell 
AtariWorks to automatically replace all occurrences of the specified text, replace 
one occurrence and find the next. or replace only the occurrence you've just 
found. These buttons are: 
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Replace All: Click this button to replace all occurrences of the specified 
text in the document. 

Replace & Find: Click this button to replace the selected text and then find the 
next occurrence of the specified text. AtariWorks selects the next occurrence 
and waits for your further instructions. 

Replace: Click this button to replace the current selection only. 

To replace text: 

1. Choose Replace from the $earch menu (or press [Controll -A). A 
dialog box appears asking you what you want to find and what you want to 
replace it with. 

2. Type the text you want to find. 

3. Move to the second box by using the down cursor key, the mouse, or 
the (TabJ key_ 

4. In the second box type the new, replacement text. 

5. Select any of the options you want. 

6. Click one of the Replace buttons to start search and replace, or click 
on Cancel to exit. 

To cancel a search and rep/ace in progress: 

1. Press [Cantrall-C. AtariWorks stops the search and replace wherever 
it is at that point. 

Changing the Appearance of the Text 

You can change the font, type style and type size to add emphasis to or 
increase the impact of parts of your text. The font name (such as Dutch, Swiss, 
etc.) is the design of the characters. Each font can have different type styles 
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(such as boldface or italics) and type sizes (such as lO-point). You can change 
these characteristics as you're typing, or you can make a selection and then 
change them for the entire selection. 

To change the font or size of a selection: 

1. Select the text you want to change. 

2. Choose Fonts ... from the Style menu (or press [Controll -H). The 
Font Face Selector box appears. It lists the fonts that you have installed 
on your computer system from your own GDOS or SpeedoGDOS font 
sets. 

3. Choose the font name from the list. If it's the correct point size, you 
can double-click to make your selection. You can also use the scroll 
window to the right of the font list and click on the font size desired, or 
type in the font size in the box below. You can choose a size between 1 to 
144 points (2 inches tall). 

You can just change the font face or the point size of the selected block of 
text. If you just want to change the font face, erase the contents of the size box 
by hitting the [Escape] key or backspacing and select the font face you want 
and click on OK. The selected block of text will change to the font face you just 
selected without affecting the sizes y~u have used in the selected block. 

You can change typestyles in one of three ways: 

(1) To change the type style of a selection: 

1. Select the text that you want to change. 

2. Drop down the Style menu. 

3. Choose the style you want for your selection. 

(2) To change the font style while typing: 

From the Style menu, you can see that there are keyboard 
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equivalents to each of the styles available. Using these control key 
combinations while typing allows you to quickly change styles while never 
letting your fingers leave the keyboard. These keyboard equivalents are: 

(ControIJ-L: Normal, no style 
(ControIJ-B: Boldface 
(Control)-I : Italic 
(Control)-U: Underfine 
(Control)-E: Outline 

(3) To use the tool bar to change typestyles: 

On the right side of the Tool Bar is a set 01 icons for changing type styles. 
By clicking on the symbols N, B, I, U, 0 , Su, and Sb, you can then type 
text in the style represented by the symbol (or a combination of symbols) 
until you press the N icon for normal text or re-press a highlighted icon to 
deactivate the style. 

Everything you type will have the characteristics you choose until you 
change them again. If you move the insertion point to text with different font 
characterist ics. whatever you type will appear with those characteristics. 

There are no keyboard equivalents to Superscript and Subscript styles, in 
which case you can use the menu options to choose the style, then continue 
typing. However. there is yet another way to change text styles quickly-·by using 
a macro. 

The Macro Function 

The Tool Bar also contains an icon that accesses the Macro function.The 
Macro function combines the elements of font. style. and size. You can choose 
from among twenty such combinations to affect the appearance of your text. 
Macros can be saved and loaded so that style combinations used for a 
newsletter can be recalled from a previous word-processing session and 
different style combinations can be recalled for writing memos or letters during 
the same word-processing session. 

The Macro function is set up by use of the Define FonVSize/Style Macro 
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dialog box under the Style menu. The first bar of the box holds the names of the 
macros created. At the right end of the bar is the button for choosing one of the 
twenty macros available. These letter/number combinations correspond to the 
computer's function keys [Ft} through [Ft 0] ; the same function keys used with 
the [Shift] key held down correspond to functions [Ft 1] through (F20]. When you 
press the button, the list of 20 macros is displayed in a popup menu. 

For example, if you are creating macro styles for a newsletter, you may 
want to name macros for Title , Byline, Subhead t, Subhead 2, and Block Quote. 
These are the kinds of names you would type onto this first line of the Define 
FonVSize/Slyle Macro dialog box. 

! NeMsletter TutL _______ I F1 

Font : ~~~~~~D~ut~'~h~~~~~I~.~I I ~Mo~n~e l SizI! : I 12 '''''' . ~ .... . .-- , '0 'U ..... n ... 

Sty1. : I_ ~ IIlIlilIQl !l:J ~I Mone 

Below the Title/Key Definition bar are areas for choosing fonls , sizes, and 
styles. The Font box works the same as the first bar by providing a popup menu 
listing the available fonts. The Size box allows you to type in the size of the font, 
from 1 point to 144 points. You can type in Single digit and double digit numbers 
using the first two blanks, ignoring the third blank. 

The Style region includes the same icons used in the Tool Bar for 
choosing type styles. Choosing None means that you may go back to any text 
formatted wilh the macro and make individual changes in style. 
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To create a macro: 

1. Choose Macro ..• from the Style menu. The Define Font/Size/Style 
Macro dialog box will appear. 

2. Click on one of the Function Key lines (F1 , F2, F3, etc. ) and type in 
the name of your macro. 

3. Click on the Font line and choose a font. 

4. Click on the Size line and type in the size of your text. 

5. Click on the icon(s) in the Style area to choose your text style . 

6. Click on OK to set the macro and exit the dialog box. Pressing the 
function key you chose will now place you in the format mode you 
specified. 

You may repeat steps 2 through 5 until you have created as many macros 
as you need (up to 20). You may go back and add more without losing those 
you have already created. You can also go back and modify ones thai already 
exist. 

Once you have created your macros, you will want to save them for future 
use. 

To save a set of macros: 

Under the File menu, you will find the option for Save 
Format/Style ... . Use this command to name and save your macros. They 
will be saved as individual files with the extension FMT. 

To load a set of macros: 

Under the File menu, you will find the option for Load 
Format/Style ... . Use this command to load a macro set you've created. 
You will be offered the Item Selector from which to choose your macros, 
which have the extension .FMT. 
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FORMATTING A DOCUMENT 

The format of a document is how it appears on your screen or on paper. 
With AtariWorks, you can have the Word Processor do much of the formatting 
as you type. For example, you can specify thaI the first line of each paragraph 
should be indented half an inch. The Word Processor will then take care of the 
indenting--all you do is type and press the Return key at the end of each 
paragraph. 

This section shows you how to 

• Change spacing. 

• Change the alignment of text. 

• Use the ruler to adjust indentation. 

• Set tabs and make columns and tables. 

• Copy a format. 

• Format and print a document with headers and footers. 

You can have as many different formats as you want within a single 
document, but each format you choose will affect one entire paragraph. For 
example, if you double·space most of a report, but want to single space and 
indent quotations, make the quotations separate paragraphs. Once you've 
created a format style, you can copy it whenever you want to use the identical 
format. 

Using the Ruler, Tool Bar, and Formatting Commands 

The Word Processor provides two excellent visual tools for handling 
formatting of documents. Running directly along the top of your text area is the 
Ruler. With it, you can create format styles for your text. The Ru ler provides you 
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with actual measurements, in centimeters or inches, 10 determine the length of 
each line of lext relative to the page: 

• I [2, , , , , , , [3 , , , , ... 14 . , , .. , , 15, , , , , , , [6, , 

Above the Ruler, you have the Tool Bar, which was mentioned in the 
previous section. Various icons on the Tool Bar are used in formaning your text. 

Page TeJ(( 
Tab TelC1 CurS()( 

Auto Format 
Indicator 

Una 

Spao"" 
Macro 

Indicator 

The Ruler and Tool Bar are always available when you first begin to use 
the Word Processor. If you do not want to have them on the screen, use the 
Window menu and click on the toggle commands Hide Ruler and Hide Tool 
Bar. These options will change to Show Ruler and Show Tool Bar, and can be 
clicked on to do what the option says. Some formaning actions, such as 
alignment and indentation, are available only through the Ruler or the Tool Bar. 

To choose the units of measurement used by the Ruler, use the Window 
menu and click on Preferences ... The Set Preference dialog box appears. You 
will see a popup menu for choosing either centimeters or inches as your units of 
measure. 

Change Spacing 

The Word Processor lets you use single, one-and·a·half, and double 
spacing to determine the amount of space between the baseline of one line of 
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text and the next. Just click on one of three Tool Bar icons situated between the 
alignment icons to the left and the tab stop icons to the right. You can also fine­
tune the line spacing yourself, using points of type to determine the distance: 

1. Position the insertion point anywhere in the paragraph you want to 
change, or select one or more paragraphs. Use the Select AU command 
from the Edit menu to select the entire document. 

2. Choose Line Spacing ... from the Format menu. Select a spacing 
option or define your own using points of type. Click the OK button or 
press [Return] . 

--0(--

2. Click the type of spacing you want on the Tool Bar icons. 

The spacing you set remains in effect until you change it. Because spacing 
is associated with individual paragraphs, if you move to a paragraph with 
different spacing, the Tool Bar will show whatever spacing is associated with 
that paragraph. 

Note: There are approximately 72 points to an inch. Points are used to define 
the size of fonts as you will recall from the previous section of this manual. 
Thus, the capital letters of a a 12-point font are roughly 1 16th of an inch in 
height. When using scalable (SpeedoGDOS) fonts with AtariWorks, you may 
wish to follow conventional typesetting rules and set spacing according to the 
size of the font being used and add 2 more points for fonts under 30 points in 
size and 3 more points over 30 points. For example, if you use 12-point Dutch, 
you would use a minimum of 12 points in line spacing, or if you use 36·point 
SwiSS Bold, use 39 points in line spacing. 

To do this, go to Line Spacing under the Format menu and add the 
additional points (t to 255). 

Changing Alignment 

The Word Processor lets you format your text so that all the lines are flush 
with the left margin, flush with the right margin, or justified (aligned to both 
margins). You can also center text, such as tities, captions, or lines of poetry. 
When you create a new document, your text will always start out left-aligned. 
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To change the alignment: 

1. Position the insertion point anywhere in the paragraph whose 
alignment you want to change, or select one or more paragraphs. Then 
use the Select All command from 1he Edit menu if you want to select the 
entire document. 

2. Choose a type of alignment from the Format menu or click on one of 
the alignment icons located toward the left side of the Tool Bar. 
AtariWorks changes the alignment for the paragraph that contains the 
insertion point or for the paragraphs you've selected. 

The alignment you set remains in effect until you change it. Because 
alignment is associated with individual paragraphs, if you move the insertion 
point to a paragraph with different alignment, the Tool Bar will show whatever 
alignment is associated with that paragraph by highlighting one of the icons. 

Setting Indentations 

You must use the Ruler to set indentation and tab stops; these choices are 
not available from the menu. Ruler settings apply to the first paragraph in a 
selection or the paragraph containing the insertion point. The Ruler comes with 
standard settings indicated by markers. When you create a new document, the 
Ruler is already showing. 

As you move the insertion point to paragraphs with different settings, you 
can see the markers change in the Ruler. When you adjust settings with more 
than one paragraph selected, your new settings affect the entire selection. 

The Word Processor lets you set indentation on both the left and the .right. 
You also can set one indentation for the first line of a paragraph, and the same 
or a different indentation for the rest of the paragraph. If you indent only the first 
line of a paragraph, you get the standard paragraphs that you see in books. If 
you indent from both the left and right, you set off a portion of text for emphasis. 

If you indent only the lines after the first line of a paragraph, you have what 
is called Hanging Indentation. This lets you prepare a standard bibliography, for 
example. 
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To indent the first line: 

You can automatically indent the first line of every paragraph, so that 
you don't have to press the [Tab] key each time you start a new 
paragraph. 

Drag the first line indent marker along the Ru ler to the position you 
want. To see the firsHine indent marker ( . ), drag the> marker at the left 
edge of the Ruler. You'll see the box appear. As you type, the first line of 
each paragraph will automatically be indented. 

You can also use this method on previously typed text. Just select the 
paragraph(s) and follow the above procedure. To change every paragraph in 
the dOaJment use the Select All command from the Edit menu. The first line of 
each selected paragraph changes as soon as you release the button. 

To set hanging indentation: 

You can set up hanging indentation by indenting the lines following 
the first line of a paragraph. You can do this either before you begin to 
type or on previously typed text that you select. 

1. Drag the first line indent marker a little to the right, so you can see 
the entire left indent marker. Or press the [Shift] key and then click on the 
indent marker and drag. Pressing the [Shift] key gives priority to left indent 
marker. 

;:1.1:,:;, ~'::i]:~';:'~' 2. Drag the left indent marker to the position you want for the hanging 
~ ~ indent. 
asdf;lkjdf;ladj: 

kfjas<ti 3. Drag the first line indent marker back to the left edge of the Ruler, if 
necessary. 

To indent an entire paragraph: 
• 

You can set an indentation that applies to an entire paragraph. You 
can do this either before you begin to type or on previously typed text that 
you select. 
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1. Drag the first line indent marker to the position you want. 

2. Drag the left indent marker to the same position. 

To indent from the right margin: 

You can shorten a line or all lines in a selected block of text by 
indenting to the left from the right margin. In combination with a left-margin 
indent, this can produce a paragraph clearly set off from the surrounding 
text (as a "Caution" in a manual, for example). 

1. Set the pointer on the < symbol at the right margin. 

2. Click and drag to the place desired. 

Setting Margins 

Indentations and margins are not the same in AtariWorks. When you set 
an indentation, that space is added to whatever margin you set with the Page 
Setup .•• command from the File menu. For example, if the left margin is 1 inch 
and the left indent is 0.5 inch. the text will begin 1.5 inches from the left edge of 
the paper. 

Indentation affects text in the selected paragraph(s) or the paragraph 
containing the insertion point. You indent to m'ove text in from the margins. 
which you set with the Page Setup command. For instructions on setting 
margins, see Printing a Document in Chapter 2. 

Note: Unlike indentations. the margins you set apply to the entire document and 
cannot be altered within the same page. 

Setting and Using Tabs 

Tabs let you skip across the page by measured amounts. Tabs are 
measured in inches rather than in number of characters. so the text lines up no 
mat1er what font, size, or style you're using. If you want to type in two or more 
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columns, you can set a left tab stop for each column after the first one, so that 
you don't have to type spaces to get to the proper location, Center tab stops can 
be used to center a heading above a column. Right tab stops help you align 
columns along the rightmost character. Decimal tab stops can be used to align 
dollar amounts on the punctuation mark. 

Setting tab stops 

Default tabs lie at each 112-inch mark on the Ruler. You can remove these 
by setting your own: when you set a tab stop, all default tab stops to the left of 
the new one are lost. 

You can set different tab stops for each paragraph you want to modify. To 
see the tab stops on the Ruler that correspond to a particular paragraph, select 
the paragraph containing tab stops. 

, , t, , , , , t, , , J4, , , , ~5, , , , , , t6 , , , 

Left tab Center tab Decimal tab Right tab 

To set tab stops: 

Position the pointer in the blank area below the Ruter markings at 
each place you want to set a tab stop. Click for a left tab stop, press 
(Cantrall-click for a right tab stop, press (Shiftl-click for a center tab stop, 
or press (Shiftl-{Controll together and click for decimal tab stop. 

You can double-click anywhere in the Ruter formatting area to 
manually enter a tab stop. A dialog box appears with the current position 
and Left Tab as the default. Set the tab type from the popup menu and 
enter the position of the tab manually. AtariWorks will place the desired 
tab at the desired location. 

You can also change the tab type and position of an existing tab by 
double-clicking and following the above procedure. 
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To move or change a tab stop: 

Drag the tab stop symbol to a new location. When you release the 
mouse button, the text in the selected paragraph(s) or the paragraph 
containing the insertion poinl realigns under the new tab stop. A box will 
pop up giving you an exact measurement lor the placement of the tab 
stop, which you can shift left or right with the mouse button held down until 
it is in proper position. 

You can also click on a desired tab on the Tool Bar and drag it to its 
desired location on the Ruler. 

To remove a tab stop: 

Drag the tab stop down into the text area. When you release the 
mouse button, the tab stop disappears. 

Using Tabs for Tables 

By setting a series of tab stops, you can make a table. You can use tables 
to list facts or figures in several columns. 

To make a table: 

t . Set a left tab stop for each column of the table. 

2. Move the insertion point to the left edge of the screen and press the 
[Tab] key. AtariWorks aligns the insertion point with the first tab stop. 

3. Type the first entry for the first time. 

4. Press the {Tab] key to set the second column and then type the next 
entry. 

5. When you finish with the last entry of the first line, press the (Return) 
key . 

Repeat these steps for each row of your table. Use the center tab SlOp for 
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headings, right tab stops for whole numbers, and decimal tab stops to align 
dollar amounts or decimal numbers. 

Using FOl'111llts 

If you have different components throughout a document that require the 
same format, you can set the format for one paragraph and then copy that 
format to other paragraphs. The format elements you can copy are alignment, 
indentation, tabs, and spacing. (For text attributes such as font, size, and style, 
use the macro functions described earlier in this chapter.) You can copy as 
many as 128 such paragraph formats and name them. You can paste any of the 
formats from this table to the selected paragraphs. 

To copy a format: 

1 . Position the insertion point anywhere in the paragraph whose format 
you want 10 copy. 

2. Choose Copy Format ... from the Format menu or press [Control]-K. 

3. A dialog box will appear. You can type in a name for the format you 
have cteated in the chosen paragraph. You can copy as many as 128 
paragraph formats. 

To paste a format: 

1. Move the insertion point to anywhere within a paragraph or select a 
number of paragraphs. 

2. Choose Paste Format... from the Format menu. The dialog box 
appears and you may choose the format to be applied. AtariWorks 
changes the format in the paragraph to the one chosen from the Format 
table. If you want to copy a format to several adjacent paragraphs, select 
them all before pasting the format. 

You can paste a format to a blank line, to start typing a new paragraph with 
those format attributes. You may also save and load formats using the same 
options from the File menu that you used to save font style macros. 
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To Save/Load Formats: 

Choose Save FormatlSlyte ... or Load Format/Style ... from the File 
menu. An item selector box will appear. You can enter the name of the 
format file and use the extension .FMT; for example, CONTRACT.FMT, 
SCRIPT.FMT, MEMO.FMT, etc. Both paragraph format tables and font 
style and size macros are saved in the given filename. 

Formatting an Entire Document 

Some formaning options work on the printed document as a whole. You 
can set manual page breaks to keep related information together, or unrelated 
information apart. With headers and footers, you can repeat information about a 
document, such as the title or date, at the top and bonom of every page. You 
can include automatic page numbers in headers Of footers. You can specify a 
title page at the beginning of a document on which headers and footers don't 
print. 

Page Break. 

AtariWor'r!.s automatically sets page breaks in all documents. Page breaks 
are affected by the top and bottom margins you set in the Page Setup ... dialog 
box. You can leave these as they appear, or change them as follows. 

To set a manual page break, cfick on the left-hand sidebar next to the line 
you want at the top of the page. AtariWorks enters a manual page break at that 
line and places the insertion point at the beginning of this line. Manual page 
breaks are shown by a doned horizontal line in the sidebar. 

To remove a manual page break, click just below the dotted line on the left 
sidebar. 

You cannot remove an automatic page break; however, you can force 
AtariWorks to adjust the position of automatic page breaks by inserting manual 
page breaks so that AtariWoft(s repaginates the document. 

Adjusting the page margins on the Page Setup dialog box will also affect 
the position of automatic page breaks. 
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Headers and Footers 

Headers and footers contain information that helps you identify a 
document. They are not displayed on the screen, but appear only when you 
print a document. Headers and footers often contain the title of the document, 
the name of the author, and perhaps the date. Or a header might be used to 
center the word Confidential at the top of every page. 

You can create headers and footers in the Word Processor. Headers and 
footers can have text aligned at the left, right, or center and can include page 
numbers too. To tell AtariWorks to include the date, time, or page number, or to 
align text in a particular way, you use a set of formaning commands. 

To set a header or footer, see Using Headers and Footers toward the 
end of Chapter 2. 

Creating a TiUe Page 

Many word processor documents require a separate page for the title. The 
Word Processor provides an option for designating a title page under the 
Format menu. Click on Title Page from the Format menu. A check mark 
appears before the menu item. You can click on it again to remove it. Setting up 
a title page means that headers and footers will not be printed on the first page 
of the document. 

Setting Consecutive Page Numbers 

You may want to break a very large project into parts. You'll find it easier to 
switch between smaller documents than to move around in a single , large 
document. You can give each part its own header and footer for clearer 
identification. By default, every new document begins with page 1, but in the 
case of a multi-chapter document, you need to change the starting page 
number in subsequent word-processor documents: click on Set Page ... under 
the Format menu and a dialog box appears. You can enter the number of the 
first page in this document. 
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Special Operations on Selected Blocks of Text 

AtariWorks can also change the capitalization of the words in a selected 
block of text. These operations are supported only by pressing cenain special 
key combinations. First select the block you wish to change. Then: 

To capitalize, press [ShiftJ-[ControIJ-C. The first letter of each word in the 
selection will be changed to upper case; all other characters will be lower case. 

To make upper case, press (ShiftJ-(Control]-U. AtariWorks will conven all 
characters in the selection to upper case. 

To make lower case, press {ShiftJ -(Control j-l. All characters will be 
converted to lower case. 

To Add the Current Date or Time to Text 

Press (Shift] -IControlj-D. AtariWorks insens the date in long format at the 
current cursor position. Similarly, [Shiftj-[Controlj-T inserts the time. 

To Remove Carriage Returns and Merge Different Consecutive Paragraphs 

In order to merge different consecutive paragraphs, I.e. to remove carriage 
returns between paragraphs, just select the paragraphs you want to merge into 
one. Now press [ControIJ-M. AtariWorks will remove all carriage returns from the 
selection. If it finds two consecutive carriage returns, it will start a new 
paragraph at that point and merge the rest of the paragraphs. This function is 
not available through the Word Processor menu. It is especially useful when you 
are importing text files . 

Spelling Checker, User Dictionary, and Thesaurus 

AtariWorks also provides spelling checker and thesaurus functions. 

To check spelling in a document: 

1. If you do not wish to check the entire document, select the block of 
text you want to check. 
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2. Choose Check Spelling .•• from the s..rch menu or press [Control]-
J. AtariWorks will check all words in the selected block for spelling, 
reporting errors and offering suggestions. 

3. If the word presented is in fact spelled correctly. it means that the 
word isn't in the user dictionary. Click on Add Word to add the word to the 
dictionary. 

4. To ignore the word, press the appropriate button in the Spelling 
Checker dialog box. If you want to ignore a word whenever it appears, 
choose Ignore A". If the spelling ch9Cker finds another occurrence of the 
same word, it will ignorQ it. 

To show and edit the user dictionary: 

1. Click on the words RUser DictionaryR above the dialog box. The words 
in the dictionary are listed in the window. 

2. Delete a word by clicking on it and then selecting the DeJet. Word 
button. Similarly, if you click on Add Word, the spelling checker will add 
the word in the Replace Text box to the user dictionary. 

3. Click on Stop to end the session. 

To use the thesaurus: 

1. Place the cursor inside the word you want to check. 

2. Select Thesaurus from the Search menu or press (Shiftj·(Control]·J. 
AtariWorks will call the Thesaurus for the word requested, and show the 
different meanings of the word in the window in the Thesaurus dialog box. 

3. Click on one of these meanings to see a list of synonyms. Then click 
on a synonym to use that word instead .. 

4. Click on Stop to end the session. 
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MARGINALIA AND AUDIO ANNOTATION 

For use with Atari computers with DMA sound, these features add a new 
dimension to working with a word processor. Whether you share your Word 
Processor files with someone else who has AtariWorks or you share files on a 
network of Atari computers, Marginalia and Audio Annotation allow you to make 
use of notes that do not print when you output your document. Such notes may 
be instructions to a coworker 10 fi1l out blanks in the document or to include 
some materials with the document's printout. Or you might include a musical 
signature that merely says, Have a nice day. 

When you press (Shift] and click the left mouse bulton in the left-hand 
margin of your window, you will gel a menu that provides a number of options 
for creating embedded notes. The menu is divided into two categories of 
options. one for Sound, the other for Text. For Sound, the options include Paste, 
Load .... Play. and Delete ... 

Paste allows you to paste an .AVA file from the GEM Clipboard 
(SCRAP.AVA). When using an Atari Falcon030, you may also record into 
AtariWorks with a microphone, using the System Audio Manager desk 
accessory. 

Load ... brings up a file selector for choosing the .AVA file you wish to use. 

Note: Either pasting or loading will leave a speaker icon on the left margin of 
the document. 

Play allows you to hear the .AVA file that has been pasted into place. 

Delete ... allows you to delete the Audio Annotator icon. 

Holding the mouse pointer down on the sound or Marginalia icon allows 
you to move them up and down in the document so that you can position them 
exactly where you want them. The standard file format for the Audio Annotation 
is the Audio·Visual Research .AVA format . For more information on how to 
create .AVR files, see the appropriate documentation that came with your 
computer. 
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The Marginalia notes can be anached just as easily. The Text portion of 
the margin menu includes the following options: 

Enter ... opens the Marginalia memo box. You type in your message at the 
cursor. The editor is not as sophisticated as the Word Processo r's editor: type in 
your message the usual way , using [Backspace) to erase or correct mistakes. 
Click on OK to save your note. 

Show ... opens the Marginalia memo box with the message completed . 

Delete ... allows you 10 delete Ih~ message and the note icon. 
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ILLUSTRATING A DOCUMENT 

Drawing Lines and Shapes 

You can use lines and shapes to make your written documents look more 
distinctive. Insert thin vertical lines between the columns of a newsletter. Create 
organizational charts, or put a box around a key article. Frame charts, 
photographs and illustrations. Keep track of revisions by crossing out deletions 
and circling insertions. Using the Word Processor's drawing capability, you can 
draw lines, boxes, round boxes and circles in four line thicknesses. You can 
draw right over or next to text and pictures. You either choose your tool from the 
Draw Pattern ••. option under the Edit menu or" choose a tool from the right 
hand side of the Tool Bar. 

To draw a line: "/ __ 

1. Choose Draw Pattern ... from the Edit menu or the line icon from the 
Tool Bar. 

2. Select a line width or a shape. 

3. Click the OK button 

Note: To ensure perlectly vertical or horizontal lines, hold down the [Shift] key 
while drawing the line. 

To draw a shape: C,--_) 8 
1 . Choose the box or circle icon from the Tool Bar or from the Draw 
Pattern ... option under the Edit menu. 

2. Put the cross where you want to anchor any corner of your shape. 

3. Hold down the mouse button and drag in any direction. 

4. Release the mouse button when you 're satisfied with the size and 
shape of the box or circle. Now you can type within or over anything 
you've drawn. 
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To select a drawn pattern: 

When you want to move, cut, or resize a line or shape you've drawn, 
you must first select it. AtariWorks treats these objects just like regular 
pictures or charts . 

1. Click the cursor on the picture you want to select. 

2. Choose Select Picture from the Edit menu or press [Control]-Z. 
AtariWorks puts a highlighted rectangle around the selected pattern. It 
also shows four grab handles at the four corners of the rectangle. 

You can cut, copy, paste, move, resize or change the line width of the 
selected patterns. 

To Cut or Copy and Paste a pattern: 

You can cut or copy a selected pattern by choosing Cut or Copy 
from the Edit menu. Cut removes the pattern from the document and 
places it in the clipboard as a GEM Metafile. Copy places a copy of the 
selected pattern on the clipboard. You can Paste any GEM Metafile from 
the clipboard to the insertion position. Just place the insertion point where 
you want the picture to appear and select Paste from the Edit menu. 

To remove a selected picture: 

Just select Clear from the Edit menu or hit the [Delete] key to erase 
the selected picture from the document. 

To Move or Resize a selected pattern: 

To move the picture to another location, just click the left mouse and 
drag it to a new position. You will see horizontal and vertical lines going 
across the window as you move the mouse, telling you where the picture 
will be placed if you release the mouse at that position. 
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To resize a picture , just grab one of the handles and drag the mouse. 
AtariWorks will show the horizontal and vertical lines across the window to 
show you the size of the picture if you release the mouse button. You can 
also grab any of the four edges of the selected pattern to resize the 
picture in either the horizontal or vertical direction. 

If you press the [Shift) key to resize a line pattern , the line will snap to a 
horizontal or vertical position depending upon the slope of the line while you 
drag the mouse. 

To change the line width of a selected picture: 

If you click on the line width icon on the right side of the Tool Bar. a 
popup menu will appear showing the different line thicknesses. Choose 
the thickness you want. The selected picture will be redrawn in the line 
thickness you have chosen. 

Metafile. and Bit Image Flies 

You can import GEM metafiles and GEM bit image files from other painting 
Of drawing applications. 

To import a metafile: 

1. Choose Import Picture ... from the Edit menu. A dialog box appears 
giving you the choice of the picture you want to import. 

2. Select GEM VOl Meta'"" (".GEM"). Click on OK. A file selector box will 
appear showing you different GEM metafiles. 

3. Select the GEM metafile you want to import. AtariWorks wilt import the 
metafile into the document at the cursor position. 

To import a GEM bit image: 

1. Choose hnport Picture ... from the Edit menu. A dialog box appears 
giving you the choice of the picture you want to Import. 
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2. Select GEM VOl Bit Image file(",IMG") . Click on OK. A file selector 
box will appear showing you different GEM bit image files . 

3. Select the GEM bit image file you want to import. AtariWorks will import 
the bit image file into the document at the cursor position. GEM bit image 
files are not visible on the screen. Instead, you will see a rectangle box 
with a cross in it. When you print the document, the bit image file will 
appear in the size and place you wanted. 

The width of the Imported picture (GEM metafile or bit image 'ile), as 
it is drawn in the window, will depend upon the current margins you have 
set for the current paragraph. If the width of the picture is greater than the 
margins, the picture is shrunk to 'it the margins. The aspect picture of the 
original picture is maintained. 

To change the font or size of a selected metafile picture: 

You can change the font and/or size of all the text in a GEM metafile 
in your document. Just select the metafile whose font and size you want to 
change. Choose Font ... from the Style menu. The Font Face Selector 
dialog box will appear. Select the font and/or size you want and then click 
on OK. AtariWorks will change the font and/or size of text in the metafile 
to the one you just selected. This change is irreversible. 

To hide or show a picture: 

Sometimes when you have a very complicated picture in your 
document, all operations on the document will slow down, because the 
picture has to be redrawn repeatedly. To avoid this, select the picture and 
choose Hide Picture from the Edit menu. A dialog box will appear asking 
you the name of the picture to be shown when it is hidden. AtariWorks will 
draw a rectangular box in place of the picture with its name in the upper 
left·hand corner of the rectangle. So if you have muhiple pictures in your 
document, you can name them differently when you are hiding them. 

To correct the aspect ratio: 
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You can correct the aspect ratio of a selected picture according to the 
original aspect ratio in which the picture was drawn. Say you have 
imported or pasted a picture and you resized it. In order to bring it back 
into the same aspect ratio as when it was created, choose Correct 
Aspect Ratio from the Edit Menu. AtariWorks will take the current width 
of the picture and readjust it's height so that the original aspect ratio of the 
picture is maintained. 
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DB 

THE DATABASE CIr 
The AlariWorks Database lets you creale an automated fi ling system. With 

your information stored in the Database, you'll have quick access to any 
combination of records. Using simple rules. you can sort through a base of 
information to create reports and print many different reports from a single 
database. Each report will contain just the particular information you want to pull 
from the database document. 

This part of the manual explains how to creale and use database 
documents: 

• Creating a Database Document shows you two ways to view a 
database document and how to create a new database document and add 
information to it. It also explains how to correct mistakes as you make your 
entries. 

• Editing a Database Document shows how to change your information 
or change the way it's presented. It also explains how to use computed fields. 

• Organizing a Database Document shows how to quickly put your 
information in order, how to find what you need, and how to make several 
smaller, specialized database documents out of one large one. 

• Making a Report shows how to define and print a repon. You 'll learn 
how to sum the contents of your fields and produce a grand lotal al the end. 
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CREATING A DATABASE DOCUMENT 

This section explains how to get started with the Database. It shows you 
how to : 

• View a database document in a form window and a list window 

• Sel up a new database document 

• Add new fields 

• Switch between list and form windows 

• Make entries 

An Overview 

When you firsl create a new database document, you set up fields to 
contain information. After you set up a field , you also determine how you want it 
to store information--as text, perhaps, or as a date or number. Once you've 
specified all your fields, you're ready to add information. You can organize and 
review your information in either a list window or a form window. 

You can add information to a form or a list. Because a form shows all the 
fields on the screen at one time, it's easier to enter full records using a form. If 
you only have a few fields , however, you may find it easier to make entries to a 
list. Either way, all the information goes into a single database document. 

Planning a Database Document 

You work with your database information using the fields you set up. The 
more fields you use, the more flexible your database will be. For example, jf you 
set up an address list, you could set up just two fields, "Name" and "Address". A 
database document like this has room for everyone's name and address, but it's 
not designed well for searching or sorting. If you wanted to know which names 
in your database came from a particular city, you have to break the address into 
parts. 
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A better way to set up such a document is 10 make a separate field for 
each component thaI you might wanl to search for or to sort through. For 
example, create fields like Mfirst name", "last name", "salutation", "address", 
Mcity", "state", "zip", etc., instead of having just two fields. 

Even if you don 't set up your fields in the most useful way when you first 
create a new database document, you can go back and add new fields at any 
time. 

Setting Up a New Database Document 

When you set up a new database document from scratch, you have to 
create a new AtariWorks document. Because there's no information in the 
document yet, AtariWorks asks you to set up fields fi rst. After you name one or 
more fields, you'll be able to start entering your information. 

To create a new database document: 

1. Choose New from the File menu. AtariWorks opens a form window 
and creates an empty document with the name "Untitled".You are then 
asked for the name of the first field. 

2. Type the name of your first field. 

3. Click the Add Field bunon or press the [Return} key. The field name 
you typed is accepted, and the dialog box reappears so that you can set 
up another field. 
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4. Type a name for the second field and for as many 01her fields as you 
want. 

5. Click the Done button when you've added all the fields you need. 
The dialog box disappears, and AtariWorks displays the f ields you created 
in a form in your window. 

To add a new field at any time: 

1. You must be in the form window. If there is a Show Form menu entry 
under Format. 1hen selecting it will switch you 10 a form window. 

2. Position the mouse pointer where you want the field to appear in the 
form. 

3. Drag the mouse to create a new field. AtariWorks adds the field to 
the right of the right most field in the list window. 

Looking at a Form 

Let's examine a single record from an address file in a form window. All the 
information about one person or subject, for example--with name, address, and 
so forth--makes up one record. 

Each record is divided into fields of information. The address is one field , 
the city and state are others. Each field has a name so that you know what sort 
of information to fill it with. And when you enter information, for example "221 N. 
Main", you make an entry in a field. Entries are called field data. 
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Looking at a List 

When you want to see many records at once--Io make comparisons, for 
example--you can list them. Remember that a database document can be much 
larger than a single window. You move around a large document by scrolling. 
The scroll bars at the right and bottom of the window show you where you are in 
a database document and enable you to scroll. If the document is not larger 
than the window, no scroll bars will appear. 

Switching Between List and Form Windows 

At the top of the Format menu, you will find either Show List or Show 
Form. Click on Show Form to show the form window or click on Show List to 
show the list window (this toggle item can also be invoked by pressing [Control]­
L on the keyboard). 

To move from a form window to a list window by clicking the mouse: 

• Double-click anywhere in the white space of a form window. 
AtariWorks displays the list and scrolls to display the record that was 
displayed in the form window. 

• Double-click the box to the left of any record of a list window. 
AtariWorks displays the form, with the record you selected showing. 

Making an Entry in a Record 

An entry is the content of a field for a single record. An entry can be blank 
or it can contain some information. To enter information into an entry, you first 
select the field, then stan typing. You can type this information into either a list 
window or a form window. When an entry is active, you can change its contents. 

To make a Database entry: 

• In a form window, select an entry by clicking on it. The entry you 
click becomes the active entry. 
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• In a list window, you can select an entry only in a record that 
already contains information, or in the first blank record. 

When you type, the information appears in the entry bar at the top of the 
screen (but not in the active entry). The Cancel box and the OK box appear to 
the left of the entry bar. The Cancel box restores the entry to what it was before 
you began typing. The OK box enters what you have typed. 

Record! 
no. 01 

The Database can read times and dates in most formats that you might 
want to use, but converts them to its own standard formats . For information 
about typing dates and times, see Changing the Format of a Field later in this 
Chapter. 

You can type up to 255 characters for an entry. Even if the field is too 
narrow to display all the characters, you can scroll the contents of the entry bar 
left or right using the arrow buttons or by pressing (Control) and the Left or Right 
Arrow keys. 

Deleting a Record 

To delete a record: 

1. From a list window, select the record to delete by clicking on the box 
to the left of the row of entries. From a form, select any field. 

2. Select Delete Record from the File menu or press [ContoIJ-K. (To 
merely blank the fields and leave the record in place, use Delete instead.) 
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EDITING A DATABASE DOCUMENT 

Database documents are dynamic. You'll often need to update your 
Database documents, changing old information and adding new information. 

This section explains how to: 

• Select information 

• Change the appearance of fields in a form 

• Change the way information is displayed in a field 

• Calculate with the Database 

• Rename a field 

• Size and arrange fields in both form and list windows 

• Insert a record 

• Show a grid 

• Copy information 

• Make corrections and remove information 

If you want to rearrange and organize your information, rather than change 
it, see Organizing a Database Document later in this chapter. 

Selecting Information 

Before you can pertorm an action on any part of a database document, 
you must select it. You can select entries, fields, or records. Then you can 
perform adions like sorting, removing, or copying. When you make any 
selection, AtariWorks displays the number of the record containing the adive 
selection at the left of the Cancel box. This number is called the record 
indicator. 
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Norks In a list window, you can select an entry, a field 
(column) , a record (row). or a block of entries. You 
can also deselect a selection by clicking the 
deselect box at the far left of the field titles. 

When you make a selection of more than one entry, 
only one entry is active at a time. This entry is 
bordered in white. 

In a form window, you can select an entry only. 

In either type of window, when you select an entry, it becomes active and 
you can change its contents in the entry bar. When you select a field, you can 
move it, size it, change its name, or change its attributes. 

The contents of the active entry is displayed in the entry bar. Anything you 
type will replace what is d isplayed. 

Changing the Appearance of Fields In a Form Window 

When you set up a new database document, the records are displayed in a 
form window with borders around each field name and each entry. The field 
name is in bold type, and the entry is in plain type. You can change the way 
records are displayed to get different effects: 

To put borders around field names or entries, choose Border Name or 
Border Data from the Format menu. 

To put field names or entries in bold type , choose Bold Name or Bold 
Data from the Format menu. 

A command that is currently in effect is checked on the menu. To remove a 
check mark, click on the option. The commands you choose affect alilieids and 
records in a document. 

Changing the Format of a Field 

There's more to formatting in the Database than using borders or bold 
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type. You can also set field attributes that determine what kind of information 
can be kept in a field, and how that information is displayed. For example, you 
can specify that a field named MTotal CostM contain only numbers displayed as 
dollar amounts. 

Field attributes apply to field data in both lists and forms. T he normal 
settings are left· aligned plain text for non· numeric characters and right-aligned 
fixed format for numbers. 

Field attributes include the type of field , the way numbers are displayed, 
the alignment and style of text, and the number of decimal places to be 
displayed. You can also specify that a numeric field be computed or that a date 
field include the day of the week. 

With the Set Field Attributes ... command, you can customize the 
appearance of your data whenever you want. Because the field type determines 
which other attributes are available to you, you should choose the field type first. 

To set or change field anributes: 

1. Select a field or an entry in the field. 

2. Choolle Set Field Attributes ... from the Format menu. The Set Field 
Attributes dialog box appears. 

3. Click the options 
you want for the field. 

4. Click the OK 
button. 

For example , the 
combination of selections 
shown to the right will set a 
numeric field in Fixed format 
with two decimal places, set 
in boldface type and aligned 
to the right margin. 

Enter fidei Utrlbutn 

Type l Dllpl,y l D.UI Stil l e I U I,nl 

I Tut UiliJ 
1:1·11. I I Underllu I I tented 

I D.tl I I tlirrUtM II tlln l I I It, ll t I -
I TI ... II Pertent I I Show eI,y I I t_n I 
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Typing a Date 

One of the options you can choose is Date. When you specify a date field 
with the Set Field Attributes ... command, the Database gives you a choice of 
short, medium, or long displays. You can also choose to have the day of the 
week displayed with the medium and long displays. You can type the date in 
any of the following formats , and the Database will display it in the form you 
choose in the Set Field Attributes dialog box: 

• 8/10/B6 
• 8-10-86 
• 8.10.86 
· 8/10/1986 
• Aug. 10, 1986 
• August 10, 1986 

Then, depending on the options you choose, AtariWorks displays the date like 
this: 

Display 

Short 
Medium 
Long 

Show Day Deselected 

8/10/86 
Aug 10, 19B6 
August 10, 1986 

Show Day Selected 

(not applicable) 
Sun. Aug. 10. 1986 
Sunday, August 10, 1986 

You can enter the current date in an entry by pressing [Control]-O.The 
range for years is 1900 to 2100. 

Typing the Time 

AtariWorks displays time using a 12-hour clock, even if you enter a time in 
24-hour format. 

If you type: 

8:04 
20:04 
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AtariWorks displays: 

8:04 AM 
8:04 PM 



If you don't use 24-hour time, remember to include the AM or PM. If you 
don't specify this , AtariWorks displays AM. You can enter the cu rrent time in an 
entry by pressing [Controll-T. 

Important: You can change a text field to a date, time, or number field after you 
enter the data. However, if the data is not in an acceptable format when you 
change the type of field, AtariWorks deletes the data. You can, however, 
change a date, time or number field to a text field and retain all your data. 

Calculating with the Database 

A computed field contains the results of a calculation based on the 
contents of other fields. For example, a computed field in a payroll database 
document might calculate weekly wages by multiplying an "Hours Worked" field 
by a "Dollars Per Hour" field. 

Computed fields aren't meant for complex numerical analysis. They allow 
addition, subtraction, multiplication, division, and exponentiation. 
(Exponentiation raises one number to the power of another; for example, 
2"2 :: 4 and 21\3 :: 8). In computed fields, you can use all Spreadsheet functions 
except those that use ranges as arguments. For detailed information on the 
Spreadsheet functions, see Chapter 5: The Spreadsheet and Appendix A. For 
making projections or performing sophisticated calculations, use the 
Spreadsheet tool itself, not the Database. 

Computed Fields 

You can designate a computed field by using the Set Field Attributes 
dialog box: 

1. Select a field. 

2. Choose Set Field Attributes ... from the Format menu. 

3. Click the Computed option. 

4. Click the OK button. AtariWorks returns you to the form or list you 
were looking at. It also puts a "::~ character and the text cursor in the entry 
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bar, meaning that you can enter the formula right away. 

Formulas 

To tell AtariWorks what you want to compute , you enter a formula. A 
formula for a computed field can contain field names, operators, functions, and 
numbers. To include a field name, you type the name in the entry bar. 

To enter a formula for a computed field, first fo11ow the procedure for 
designating a computed field as described above, then: 

1. Type the formula at the insertion point. 

2. Click the OK box or press the [Return] key. 

AtariWorks calculates the contents of the new field from the formula you 
typed. If you included a nonexistent field name in the formula, AtariWorks 
displays an alen box. 

Renaming a Field 

If you decide to change the name of a field, you can rename it in the 
following way: 

1. Select the field. 

2. Choose Rename Field •. . from the Edit menu. The New Field Name 
dialog box appears. The current name is selected, so you can just type 
the new name to replace it. 

3. Type the new name in the dialog box. 

4. Click the OK bunon or press the [Return] key. AtariWorks replaces 
the old name with the new one. 

You can also double click the field name to see the New Field Name dialog 
bo"x. 
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Sizing and Arranging Fields in a Form Window 

You can change the size and arrangement of fields in a form window 
whenever you want. 

Works file Edit 
1.25 

To change the size of a field in a form 
window: 

1.Position the pointer on the right 
edge of the field data box. The arrow 
turns into a pointing finger. 

.Q lQt n Qm p. 2.Hold down the mouse button and 
drag to the right or left until the box is 

the size you want. While you resize the field, AlariWorks displays the size 
of the field in the current measurement system in the left side of the entry 
bar. This is primarily an aid to calculating printed area. Fields can range 
from 0.1 inch to 10.0 inches. 

To move a field: 

You don't have to leave fields where you first created them. 
AlariWorks lets you move fields to wherever they make the most sense to 
you. 

1. Position the pointer over the field name you want to move. Hold down 
the left mouse button and the pointer turns into a hand. 

2. Drag the field to its new location. 

If a field won't fit where you want to put it, you'll have to make room for it. 
You can make it smaller, or make surrounding fields smaller, or move another 
field out of the way. 

Sizing and Arranging Fields in a List Window 

The width or placement of fields in a new list may not satisfy you. They're 
alilhe same width, and their order is based on the order in which you first typed 

4·13 Chapter 4: The Database 



the field names. But in an address book, for example, you might want the "first 
name" field to be wider than the "middle initial" field. It would make more sense 
to have "last name" as the first field, rather than "zip code" or "state." AtariWQ.rks 
lets you size and arrange your fields however you want them at any time. 

To change the width of a field in a list window: 

1. Position the pointer on the right edge of the field name box. Hold 
down the left mouse button and the arrow turns into a pointing finger. As 
you drag to adjust the field size, a dotted line shows you where the new 
edge of the field will be. The size of the field in the current measurement 
system appears in the left side of the entry bar. 

2. Drag to the right to widen the field, or to the left to narrow it. 

Bob !Smith , 

Inserting a Record 

To move a field in a list window: 

I.Position the pointer on the name 
of the field you want to move. 

2.Hold down the left mouse button 
and the pointer turns into a hand. 
Drag the field to the right or left. 

You can add a new record between other records, in both a list and a form 
window: 

1. Select a record in a list window, or scroll to a particular record in a 
form window. 

2. Choose Record Insert from the Edit menu. AtariWorks insens a 
blank record before the selected or displayed record. You can also use 
[ControIJ-1 from the keyboard to insert a record at the highlighted spot. 
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Showing the Grid 

In a list window, lines separate each column and row. You can choose to 
turn this grid on or off. This is a toggle item from the Format menu. Choose 
Grid to show the grid or No Grid to hide the grid. 

Copying Information 

You can copy individual records, fields, or entries, and blocks of records, 
fields, or entries. Copying within and between documents saves you from 
having to retype similar information. For example, if you have ten people in your 
address book who live in Seattle, Washington, you can type the city and state 
once, and copy the rest. Although you can copy in both list and form windows, 
it's easier in a list window, because you can copy multiple records at once. 

To copy a record: 

1. Make sure you're in a list window. 

2. Click the record selector box at the left of the record you want to 
copy. 

3. Choose Copy from the Edit menu. (Or use [ControIJ-C from the 
keyboard. ) 

4. Select the row where you want the copy to go. 

5. Choose Paste from the Edit menu. (Or use [Control]-V from 
keyboard. ) 

There are times when you 'll want two or more records to have the same 
entry for a particular field. 

To make multiple copies of an entry: 

1. Make sure you 're in a list window. 

2. Select the entries you want to copy. 
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3. Choose Copy from the Edit menu. (Or use [Control]-C from 
keyboard.) 

4. Select the entries to receive the copy. 

5. Choose Paste from the Edit menu. (Or use [Controi]-V from 
keyboard.) AtariWorks fills in the selected entries with a copy of the 
Information. 

Now you can select these two blocks of entries to copy and paste into the 
next two records. Then you can select the four identical blocks of entries and 
copy and paste them into the next four records. You can repeat this process to 
fill your records as often as you need to. 

Making a Correction 

When you find a typing mistake in an entry, you can correct it: 

1. Select the entry containing the mistake. 

2. In the entry bar, put the pointer to the left of the mistake. 

3. Press the [Delete] key to erase the entry. 

4. Type the correction. 

5. Click the OK box or press the [Return] key. 

Note: After selecting the entry containing the mistake, pressing the space Bar 
will put the edit cursor at the end of the string. 

Removing Information 

AtariWorks lets you remove information from a Database document in 
three different ways: 

• Cutting takes information out of a database document and puts it on the 
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Clipboard. This is useful for cutting and pasting as well as for removing 
information. You can cut records, entries, and blocks of data . 

• Clearing permanently removes records, fields, entries, or blocks. 
Cleared information does nol go on the Clipboard . 

• Deleting a field removes a field from the database document including 
the field name and all entries. This should only be used to remove an entire field 
that you don't need anymore. 

If you cut or clear information, then decide you don't like the result, use the 
lUnda] key right away to put everything back. 

To cut information: 

If you cut a field or entry, AtariWorks cuts the contents. but leaves a blank 
field or entry in its place. If you cut a record, AtariWorks removes the record and 
closes up the empty space. 

1. Select the information you want to cut. 

2. Choose Cut from the Edit menu or press [Cantrall-X. AtariWorks 
takes the information out of the database document and places it on the 
Clipboard. You can paste what you cut back into the database document 
at a location you select. 

To clear information: 

When you clear information, AtariWorks blanks the selected entries. 
If you clear a field, entry, or record, AtariWorks clears the entries, but 
leaves a blank field, entry or record in its place. 

1 . Select the information you want to clear. 

2. Choose Clear from the Edit menu. AtariWorks removes the 
information from the database document, but does not put it on the 
Clipboard. If you reconsider, choose the Undo command before you do 
anything else. 
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To delete a field: 

When you delete a field, AtariWorks removes it from the document 
and closes up the space it left behind. 

1. Select the field . 

2. Choose Delete Field from the Edit menu. 

To paste the contents of the Clipboard: 

If you cut a selection, you can paste it back into a database 
document at a location you select: 

1. Select a record or field, or the upper-left entry of a block of entries 
that you want to paste to . 

2. Choose Paste from the Edit menu or press (ControIJ-V. AtariWorks 
fills in the selected entries with the information from the Clipboard. 

ORGANIZING A DATABASE DOCUMENT 

This section of the manual shows you how to organize a database 
document so that you can find information easily: 

• Sort information into alphabetical, numerical, or chronological order, 
backwards or forwards. 

• Find information. Scroll to view those fields that contain the characters 
you specify. 

• Match records. Quickly call up the records that contain the information 
you specify. 

• Use record selection rules. Use up to six criteria to have AtariWorks 
show you records with specific information only. By using record selection rules 
and then saving the selected records with another name, you can create 
subsets of your database document. 
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Sorting Information 

If your records aren't in the order you want, sort them. Sorting arranges 
records in alphabetical, numerical, or chronological order. either backwards or 
forwards. You can sort through any field, in both form and list windows. 

Sorting is more than just putting A before Z in your database document. 
You can do successive sorts on different fields to group your records just the 
way you want them. Each sort is done individually by repeatedly choosing the 
Sort command. . 

For a multi·level sort, you first must break down the levels into priorities 
and then sort on the field you're most interested in last. For example, to get an 
address list in order by last name and then by first name, you'd first sort the first 
name field. For each level of a multi-level sort, AtariWorks retains the order of 
all previous sorts. 

Multi-level sorting lets you presort a large mailing list. For example, you 
can group the records in your list in order by last name, first name, city, state, 
and zip code. When you put labels on your mass mailing, it will already be 
sorted by each of these categories. 

To sort information: 

t. Select the first field you want to sort. 

2. Choose Son from the Edit menu or type (ControIJ-Z. AtariWorks tells 
you which field you're sorting on, and gives you a choice of sorting 
sequences. 

3. Click the appropriate sequence. 

4. Click the OK button. 

5. Repeat the procedure for any other fields you want to sort. 
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Finding Information Quickly 

Sometimes you need to locate specific information in a database 
document. 

To find the entries: 

1. Choose Find Field .•• from the Select menu or type [Contrail-F. 
AtariWorks displays a dialog box. 

2. In the dialog box, type the information you're looking for. 

3. Click the Find Next button. AtariWorks activates the first entry thaI 
contains your information. When AtariWorks looks for the information. it 
searches all fields in one record, then searches the next record, and so 
on. Searching ignores whether the text is upper- or lower-case. 

To continue finding entries that contain the information you specified, 
choose Find Field ... again. The characters you typed will still be in the text box, 
so you just click the Find Next bunon. 

Matching Records 

The Match Records ... command is a shortcut to seeing a subset of a 
database document. You type a few characters or words and let AtariWorks 
match the records containing that information. When AtariWorks is done, you'll 
be looking at only those records that contain the information you specified. 

You don't even have to type a whole world or number--jusl enough 
information 10 begin a match, like "Chi" when you're searching for records 
containing "Chicago". 

Suppose you want to find all the records in the database document 
Addresses that contain the word "Hillside": 

1. Choose Match Records ... from the Select menu or type [Controlj·M. 
AtariWorks displays a dialog box. 
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2. In the dialog box, type the information you want AtariWorks to look 
for. For this example, you would type Hillside. 

3. Click the OK button. AtariWorks displays any records that contain 
your information. If nothing matches, AtariWorks tells you so and lets you 
try again. 

Match Records ... presents you with a subset of your set of records. You 
can do any kind of operations with the matched records. If you'd like to turn your 
selection into a separate database document, see Saving a Selection with a 
Different Name at the end of this section. You might want to do this if you made 
a selection in order to give someone a subset of your database document, or to 
make mailing labels from a subset of your document. 

To See All Records 

To be able to see all the records and use the rest of the Database 
commands, you must go back to the full database document. 

1. Choose Show All from the Select menu or press [Control)·E. You 
will see that the check mark before Match Record has disappeared and 
now it has appeared before Show All . This shows that all the records are 
being displayed currently. 

2. AtariWorks displays all your records . 

Using Selection Rules 

When you're looking for very specific information. you can set up record 
selection rules. AtariWorks follows your selection rules as it searches for the 
information you want, then shows only those records that meet your selection 
rules. Selection rules are especially useful when you want to print your 
information in a report. 

How Selection Rules Work 

Record selection rutes aren't as complicated as they sound. You go 
through a record selection process yourself when, for example, you look in your 
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address book for people who work in San Diego. You teU yourself, ~Look for 
people who are business associates and work in San Diego." Or, to use the 
language of selection rules: the "Type~ field contains Business and the 
"Location" field contains San Diego. 

In the same way, you use selection rules in AtariWorks to find information 
that meels your criteria, usually to make some kind of decision. For example, 
the auditor of a department could have AtariWorks find all months in which the 
director spent over the allotted $300 per month and the months in which the 
director traveled frequently, to see the impact of travel on the budget. 

Parts of 8 Selection Rule 

A record selection rule is made up of three components : a field name, a 
relational operator, and some record comparison information. The field name 
corresponds to a field in the active database document. The comparison phrase 
comes from the foUowing list: 

equals 
is not equal to 
is greater than 
is greater than or equal to 
is less than 
is less than or equal to 
is blank 
is not blank 

contains 
does not contain 
begins with 
ends with 
does not begin with 
does not end with 

For text fields, you'll have all the above phrases available. For numeric, 
date, or time fields, you'U have those on the left in the above list. The record 
comparison information is what you type to use for the comparison. 

To make a simple selection rule: 

1. Choose Select Records ... from the Select menu or press [Controll­
A. A dialog box appears, containing a field name box, a comparison 
phrase box (you can scroll through all fields and phrases by clicking the 
appropriate scrolling buttons), and a box to type in the comparison 
information. 
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2. From the field name box, select the field you want AtariWorks to use 
in the comparison. Click on the Field Name field in the dialog box. A 
popup list appears, showing all the field names in your database. Select 
the field name you want. 

3. From the Relational Operator, select the appropriate comparison 
phrase. Click on the phrase field. A popup list appears. showing you all 
the comparison phrases available. Select the comparison phrase you 
want. 

4. Type the retord to be compared in the Current Rule box. 

5. Click the Install Rule bunon. AtariWorks displays the completed 
selection rule. 

6. You may repeat steps 1 - 5 for up to six criteria of your selection rule. 

7. Click the Select bunon to have AtariWorks find the records that meet 
your selection rule. AtariWorks searches through your database document 
looking for records that match up. It then displays just those records. If 
AtariWorks can find no matches, it displays an alert box. 

When you're looking at selected records , you see a subset of the total 
database document. The rest of the records are still in memory and are still 
included in the overall document. If you want to look at all your records again , 
choose Show All from the Select menu. If you 'd like to turn your selection into 
a separate database document, see Saving a Selection with a Different 
Name at the end 01 this section. You might want to do this if you made a 
selection in order to give someone a subset of your database document, or to 
make mailing labels from a subset of your document. 

Setting up More Complex Rules 

A single selection rule helps to find information, but with AtariWorks, you 
can be much more specific. Connectors (And and Or) let you link together up to 
six selection rules. 
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Using Connectors 

After you set up a single selection rule, but before you carry out the 
selection with the Select button, AtariWorks presents you with these two 
connectors to choose from: 

And lets you link together multiple selection rules. Each additional rule 
eliminates more of the records in your database document, so you zero in 
on the ones you need. When you use And between two selection rules, 
AtariWorks selects only those records that satisfy both rules. 

Or lets you choose between multiple selection rules. If a record doesn't 
match the first rule, it might match the second or third. 

You can use these connectors separately or in combination. For 
example, a developer examining real estate holdings in EI Paso might use 
selection rules like these: 

Location equals EI Paso 
And Type equals Shopping Center 
Or Location equals EI Paso 
And Type equals residential 

These rules eliminate all other properties, such as office buildings or 
hotels, and aU properties not in EI Paso. Notice that the following set of rules 
would not produce the same result: 

Location equals EI Paso 
And Type equals Shopping Center 
Or Type equals Residential 

Because the And connector takes precedence over the Or connector, this sel of 
rules would select records containing shopping centers in EI Paso, plus all 
residential properties (regardless of location). 

You can also use connectors to extend a comparison, setting up a 
range of items, rather than a single item, to match. An example of a range is: 
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Sales are greater than $100,000 
And Sales are less than $1,000,000 

To Add Further Rules to Your Original Rule: 

1. If you already clicked the Select bunon after installing your first rule, 
choose Select Records ... from the Select menu again. Otherwise, you're 
ready to add another rule. 

2. Click And or Or. 

3. Select a field name. 

4. Select a relational operator phrase. 

5. Type the record into the current rule box. 

6. Click the Install Rule bunon. 

You can continue to add rules in this manner until the dialog box is full. 
When you're done, click the Select button to select the records that match your 
selection rules. 

Changing Your Mind 

If you make a mistake or decide not to make a particular selection, or if you 
just want to see all the records, you can cancel the record selection rules or 
make new ones. 

Until you click the Install Rule button, you can change any part of your 
rule. Just select different items from the list boxes or type new comparison 
information before you click the Install Rule bunon. 

To remove a rule after you click Install Rule, click Delete Rule. 
AtariWorks erases the last installed rule. You can repeat this step for as many 
rules as you have. 
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To see all records, Choose Show All from the Select menu. AtariWorks 
now shows all the records in the database. 

Saving a Selection with a Different Name 

If you have a main database document that you use to store most of your 
information, you can create several smaller documents from it The smaller 
documents would contain subsets of the information in the main database 
document. 

For example, a subset of a customer list might contain shipping addresses 
for the northeast region. If you save the northeast region data alone in another 
file, you can print mailing labels just for northeast customers in conjunction the 
Word Processor. 

To create a subset of a Database document: 

1. Use the Select Records •.. or Match Record ... command to display 
only the records you want to include in the smaller document. 

2. Delete any fields you don't need in the smaller document. 

3. Choose save As ... from the File menu. 

4. An alert box appears asking you if you want to save the selected 
records only. Choose yes if you want to save the selected records only. 

Note: "Selected records" does not mean the records which are 
highlighted. It means the records you selected by means of Selection 
Rules. 

5. The Save As dialog box appears, giving you a chance to save the 
information with a different name or on a diMerent disk. 

6. Type a new name for the smaller database document. 

7. Click on OK or press the return key. AtariWorks saves the subset of 
your database in a new name. 
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MAKING A REPORT 

A report presents a table of information, with a record on each row. A 
report provides a form in which data can be compared or in which a relationship 
among data can be presented. Using the methods learned in the previous 
section, you can now create such a report. 

Any database itself is a report. You can use different sets of selection rules 
or matching patterns to select a subset of the database. This is called a report. 
You can use Sort to rearrange the records in this subset, and use the mouse to 
rearrange the fields and resize them. You can set the fields to be summed and 
also the controlling field. 

You can change your set of selection rules in the Select Records ... dialog 
box, or change the string in the Match Record ... dialog box to produce a new 
report. 

A report definition tells AtariWorks what information to print from a 
database document. You use record selection rules to choose just the records 
that meet the criteria for your report. For example, if you're looking at all credit 
ratings for customers, you can print a report of just those customers whose bills 
are 90 days past due. 

Setting up a Report Definition 

To set up a new repon definition: 

1. Specify headers and footers, paper size, and margins with the Page 
Setup ... command from the File menu. 

2. Create or review any record selection rules, and make any necessary 
changes. 

3. Size and arrange fields, and specify which fields to print by moving 
any you don't want printed outside the report margin. 

4. Specify any field to sum, using options under the Control menu. 
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5. Specify when to subtotal groups of records. using options under the 
Control menu. 

6. Specify when to start a new page after a subtotal . using options 
under the Control menu. 

7. Specify whether to print a report using a grid, using options under the 
Format menu. 

All at this information makes up your report definition. The rest of this 
section details the procedures. 

Setting Up Paper Size and Margins 

Use the Page Setup ... command from the File menu to set up your report 
page. You need to do this from the start because paper size and margins 
determine the amount of information that can be printed for each report. 

You'll be able to see your margins at once by looking at the page breaks in 
your window. If you need to fit more fields in. you can decrease the margins by 
using the Page Setup ..• command again. For complete information about using 
the Page Setup ... command. see Page Setup in Chapter 2. 

Setting Up Headers and Footers 

Use Header/Footer ... from the File menu to set up your header and footer. 
For complete information about using the Header/Footer ... command, see 
Headers and Footers in Chapter 2. 

Arranging the Fields to Print 

When preparing a report definition, you decide in what order to put the 
fields and which fields to include in the printed report. Once you have made 
these decisions. you may need either to adjust some field widths or adjust the 
margins of your report. 

Before you begin. look at the database window and locate the edge 
markers. The page breaks show you how wide your report will be. You 
determined where these markers are when you set the left and right margins in 
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the Page Setup dialog box. Fields before the first page break are included in the 
report. Fields completely or partially to the right of this won't be included. 

To Rearrange Fields 

You can rearrange the horizontal position of the fields to be printed by 
dragging the field name of any field left or right. 

To Move Fields In and Out of a Report 

If you have many fields in your database document, some of them may not 
fit within the margins of your report. In this case, you can take unwanted fields 
out of the report by dragging. In other cases, however, you may not have 
enough fields to completely fill the space between the edge markers. When this 
occurs, you will not be able to drag out unwanted fields until you either widen 
the fields or change the margins with the Page Setup command. The fields you 
include in a report must be wide enough to fill the area to the page break. 

To put a field out of a report, drag the field to the right so that the page 
break occurs before it. To put a field back into a report, drag the field to the left 
so that the page break occurs before the page marker. 

Using the Control Menu 

Your database document might be enhanced by including totals that are 
sums of a column of numbers. For example, a payroll report might sum the total 
payroll. AtariWorks also lets you set up subtotals, such as payroll per 
department in addition to the total payroll. With the Control menu in the 
Database, you can select fields to be totaled or sub totaled. You can review the 
totals before printing the report, and you can create summary documents with 
just this totals information. 

When you use the Control menu to specify totals, subtotals, or new 
pages, the commands in effect for a selected field are checked on the menu. To 
change your specifications, choose any command again to remove the check 
mark. The simplest total sums atl the numbers in a field. 
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To total a field: 

1. Select a numeric field that you want totaled. 

2. Choose field to Sum from the Control menu. The total for that field 
will appear at the bonom of the field when you print the report . 

For fields that you've specified to be totaled, you can also specify two 
kinds of subtotals. In both cases, you will get more meaningful results if you sort 
your records before specifying the subtotals. 

To Subtotal When Field Data Changes 

You can set up a report to print subtotals whenever the contents of a 
specified key field changes. Many database documents can be organized into 
divisions or groups. For example, payroll can be divided into departments. For a 
payroll database document, you might want a subtotal whenever the 
department name changes. In this case, the field containing department names 
would be the key field. 

Here 's how to set up such a subtotal: 

1. Select a numeric field that you want to subtotal. Just click the field 
name. 

2. Choose Field to Sum from the Control menu. 

3. Select the key field on which you want the subtotals based. 

4. Choose Total on Field Change from the Control menu. 

When you print the report, AtariWorks will print a sublotal every time the 
contents of the key field changes. For example, in a payroll report, you 'd get a 

'subtotal after all the entries for Manufacturing, and another after all the entries 
for Sales, and so forth. Then AtariWorks prints a grand total at the end of the 
report. 
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To Subtotal When the First Character in a Field Changes 

You can also set up a report to print subtotals whenever the first character 
in a specified key field changes. For example, you might want to get subtotals 
for each group of records having an entry in the last name field beginning with 
the same letter, so that you subtotal A's, 8 's, C's, and so on. 

To set up this kind of subtotal: 

1. Select a numeric field that you want to subtotal. Just click the field 
name. 

2. Choose Field to Sum from the Control menu. 

3. Select the key field on which you want the subtotal based. 

4. Choose Total on 1st Char Change from the Control menu. 

When you print the report, AtariWorks will print a subtotal each time 
the first character of the entries in the key field changes. 

To Print a New Page After a Subtotal 

To make reports easy to read , you may prefer to start a new page after 
printing each subtotal. That makes a subtotal the last printed line on each page. 

To start a new page after each subtotal, first complete either of the two 
procedures shown above for specifying subtotals. After you have chosen either 
Total on Field Change or Total on 1st Char Change, choose New Page After 
Total from the Control menu. When you print the report, AtariWorks will skip to 
a new page after it prints each subtotal. 

Printing With or Without a Grid 

Works normally prints a grid separating the records and fields in a report. 
To print the report without a grid, choose No Grid from the Format menu. (This 
is a toggle item; clicking on it again will bring the grid back.) 
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Storing a Report Definition 

After you have completed a report definition, you can choose either to 
preview any subtotals or totals you may have specified (see Previewing Report 
Totals below), or to print the report immediately. AtariWorks stores the report 
definition with the associated database document. When you later save the 
database document, the report definition is saved along with it. 

Previewing Report Totals 

After setting up your report definition, if you've specified fields to be 
summed, you can preview the totals and subtotals before you print the report. 

To preview the totals, Choose Copy Totals from the Edit menu. Copy 
Totals is available only after you have specified at least one field to be 
summed. 

When you specify subtotals with the Total on Field Change command, 
AtariWorks copies the records containing subtotals and the grand total to the 
Clipboard. When you specify subtotals with the Total on 1st Char Change 
command. AtariWorks copies the first record of each group to the Clipboard. 
substituting the subtotal of each entire group for the number retated to each 
particular record. You can then open the Clipboard to see this information. 

To Create Summary Documents 

Once the data is on the Clipboard. you can use it just like anything else on 
the Clipboard. For example. you can paste the information into a Word 
Processor or Spreadsheet document to create a summary document containing 
just the totals information without all the supporting numbers. 

Printing a Report 

There are two stages in printing a report: preparing the information and 
printing the report. 
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To prepare your information: 

1 . Open the Database file from which you want to print a report. 

2. Sort the records to have them appear in the order you want. 

3. Review any formatting characteristics specified with the Set Field 
Attributes ... command. 

4. Change the Record Selection rules to get the subset of records you 
want for your report. 

5. Set the Control menu. 

To print the report: 

1. Choose Print from the File menu or type [Control]-P. 

2. Review the options to make sure they're aU set as you want them, 
and make any necessary changes. 

3. Click the OK button. AtariWorks prints your report. If your printer is 
disconnected or you run out of paper, AtariWorks displays a message. 

Working with Reports 

Many businesses print regular revisions of reports--like address lists, 
customer lists, bad check lists, or payment overdue lists. For example, the first 
time you define such a report may be the only time you need to because you 
can select that same report definition each time you need to print the report. As 
long as your database document contains the fields contained in the report 
definition, there's nothing else to worry about, even if the contents of the fields 
change completely, or you go ahead and change the record selection rules and 
settings in the Control field. 
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55 

THE SPREADSHEET 

The AtariWorXs Spreadsheet automates the kind of statistical 
determinations you would otherwise pertorm with a sheet of paper and a 
calculator: taxes, sales projections, cash-flow analysis, or personal net worth 
statements. The Spreadsheet gives you ceUs to fill with labels, numbers, and 
formulas. You type in the data, and AtariWorks does all the calculating for you. 

You can change the numbers to see what happens, and let AtariWorks 
recalculate them automatically. Once you have the numbers in place, you can 
chart your figures to see how they look. Then, when you change a number, you 
can watch the chart change at the same time. When you have the result you 
want, you can print it. 

The formulas you enter into the Spreadsheet can include everything from 
simple addition and subtraction to trigonometric equations and logical 
comparisons. 

The following five sections explain how to use the Spreadsheet: 

• Entering Information shows you what a Spreadsheet document looks 
like, how to type labels, numbers, and formulas into the Spreadsheet, and how 
to use the Spreadsheet's built-in functions. 

• Working with the Spreadsheet shows how to make changes or 
additions to your Spreadsheet document, and different ways to look at it. 

• Formatting and Printing shows how to arrange your information on the 
screen and prepare for printing. 

• Charting a Spreadsheet Document describes the Spreadsheet's 
charting capability. 

• Spreadsheet Functions describes the Spreadsheet's built-in functions. 
This information appears as Appendix A at the back of this manual. 
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ENTERING INFORMATION 

In this section, you'tllearn how to 

• Recognize the parts of a spreadsheet document, and design your own 
documents. 

• Select parts of a spreadsheet document. 

• Enter and correct information. 

• Use labels and values. 

• Build a formula using operators, references, and functions. 

• Avoid circular references. 

An Overview 
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This section shows you what a spreadsheet document looks like in 
AtariWorks, explains what a spreadsheet is, and shows you how to design your 
own for maximum effectiveness. The Spreadsheet helps you analyze numbers 
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that you arrange in rows and columns, such as budgets or financial statements. 
You can change the numbers to see what happens when the Spreadsheet 
makes a recalculation. You can also chart your numbers with the Spreadsheet. 
Change a number in a document, and the chart instantly ,reflects the change. 

A spreadsheet document is made up of vertical columns and intersecting 
horizontal rows. Each column has a lenered heading (labeled A to Z, then AA, 
AB, and so on up to IU). Each row has a numbered heading (1 , 2, 3, and 
onward to 9999). Where the columns and rows intersect, they form cells. You 
can locate a cell or refer to it with a cell reference--its column heading and row 
heading. For example, A 1 is the cell reference for the cell in the upper-left 
corner of a spreadsheet document: column A, row 1. 

You tell AtariWorks where you want to enter information by selecting cells. 
As you type, the information appears in the entry bar. You enter the information 
into the active cell by clicking the OK button or pressing the [Return] key. The 
number of cells you can fill is dependent upon the amount of memory available 
to you. 

You put numbers, formulas, and labels into cells to create a spreadsheet 
document. When you change numbers, you can see how the changes affect the 
outcome of the Spreadsheet calculations. 

Vou set up a calculation by entering a formula. For example, 2+2 is a 
simple formula. A 1 + A2 is also a formula. Using this formula, AtariWorks looks 
for numbers in cells A 1 and A2 and adds them. By placing the formula in cell 
A3, for instance, you have the sum of A 1 and A2 directly below them in A3. 

Labels make your spreadsheet documents easier to understand. A label 
consists of text, such as Total Expenses, Percent, or 1992 Projections. Labels 
explain what your numbers and formulas stand for. 

Designing a Spreadsheet Document 

You may not realize it, but you've probably prepared something similar to a 
spreadsheet document already. Maybe it was several columns of fjgures you 
jotted down for a promotional campaign, or a departmental budget you wrote on 
graph paper. It's very likely that you've done something like this before. 
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• To get started, choose a specific subject. For example, if your main 
purpose is to set up an expense report document, don 't get sidetracked by 
putting a travel budget in the same spreadsheet document. 

• Choose your components. Write down all the types of information you 
need for your calculations. When you type them into a column in a spreadsheet 
document, you will be setting up your labels. 

• Decide on a structure. Map out what goes where. A good structure not 
only lends itself to easy calculation by AtariWorks , it also makes it easy to find 
the information you need after the calculations are complete . 

• Plan the calculations. Determine equations that produce the results you 
want. These equations will become your Spreadsheet formulas. 

• Decide on the numbers. When your labels and formulas are entered in 
your Spreadsheet document, you will need only to type in the numbers to find 
your answers. 

Selecting Parts of a Spreadsheet Document 

Before you can enter information into a spreadsheet document, you tell 
AtariWorks where to put the information by selecting a cell or a range of cells. 
The information you type goes into the active cell in the selection. In any range 
of selected cells, only the cell outlined with a solid line is active. 

You can select ce11s by clicking or dragging with the mouse or by choosing 
commands from the Select menu. For more information, see the next 
subsection, Entering Information into 8 Spreadsheet Document. 

To select a single cell , click anywhere in the cell. The following list 
describes how to select various ranges of cells. 

To select a block of cells, drag from the cell in one corner of the block to 
the cell in the opposite corner. 

To select a complete row or column, click the row or column heading. 
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To select several rows or columns, drag from the first row or column 
heading to the last row or column heading. 

To select all cells through the last cell , choose All Cells from the Select 
menu. 

When selecting a range of celis, if you drag/paste the last row or column 
on the screen, AtariWorks scrolls the window and adds to the selection. 

AtariWorks considers the last cell in your Spreadsheet document to be the 
cell at the intersection -of the last row and column containing a value, a formula, 
text, or a reference. 

Entering information into a Spreadsheet Document 

You can enter either constant values or formulas into the cells of a 
spreadsheet document. Constant values can be labels (i.e. , text) or numbers. In 
the case of a formula, your entry should be preceded by a equal sign ( .. ), i.e., 
.A1+A2. 

As you type the information you want to put in the active cell, it appears in 
the entry bar, just below the menu bar. That way, you can be sure that your 
entry is correct before you use it for a calculation or a label. It won't appear in 
the active cell until you enter it (press the (Return) key). 

When you enter a constant value or a formula, AtariWorks stores it in the 
active cell and displays the formatted value in the cell. 

There are several ways to enter what you type. You can click the OK 
button, or use the keyboard as described below. 

To enter what you type and 
make the active cell ... 

... the cell on the right 

.. .the cell on the left 

.. . the cell below 

.. . the cell above 

Press these keys: 

(Tab) or right arrow 
Shift-Tab or left arrow 
Down Arrow 
Up Arrow 
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By default, the (Return] keywill take you to the cell below the active cell. 
But after you use any other key for entering the value, [Return) will follow the 
direction taken by the previous keystroke. 

You can also use these keys to move around in the document when you 
are not entering information. 

While a cell is being edited, i.e. the cursor in the entry bar is blinking, the 
left and right arrow keys will move the text insertion point in the entry bar. [Shift] 
plus the Left or Right Arrow keys will move the cursor left or right by the visible 
number of characters in the entry bar. (Control]-LefVRight key combinations will 
take the text cursor left or right by one word . 

If the cell is not being edited, Le. the buttons in the entry bar are not visible, 
pressing the (Control]-LefVRight keys will scroll the entry in the entry bar left and 
right, if it is not fully visible. 

Note: If the entry bar is not active, pressing the space bar activates the current 
entry and places the cursor at the end of the current string in the entry bar. 

Making Corrections to an Entry 

If you make a mistake while you're typing information in the entry bar, you 
can correct it. 

To cancel your typing in the entry bar: 

Click the cancel box to the left of the entry bar. AtariWorks cancels 
your typing and restores the original entry. If the original entry was blank, 
the entry bar will also be blank. 

To edit an entry: 

To edit an entry you can use the [Backspace] and [Delete) keys to 
change and type to replace it. You can also place the cursor by clicking 
the mouse at the appropriate place. The following keys are also valid 
while editing an entry: 
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Clear entry: [EscJ 

Cut to the clipboard: [ControIJ-X 

Copy to the ctipboard: [Control)-C 

Paste from the clipboard: [ControIJ-V 

Entering a Label 

labels let you write explanatory information in a spreadsheet document. 
labels make the numbers and formulas easier to understand. You can label the 
contents of a column or row, or include notes to explain how you perform a 
certain calculation. labels help other people understand your spreadsheet 
document. and also help you when you return to a document that you haven't 
used in a long time. 

You can do all sorts of creative things with labels: a line of hyphens can 
separate values in a column from their total ; a number followed by a letter (30) 
can specify a quarter of the year; a number (1994) can label a year. 

To enter a label: 

1. Select a cell. 

2. Type the label. If the label starts with a number or (:), precede it by a 
double quote mark n. 
3. Click the OK button or press the 
[Return) key. 

To fit labels into cells: 

If a label doesn't fit inside a cell, 
AtariWorks automatically runs the label 
into any blank cells that follow, cutting 
off the label at the first non-blank cell , if 
necessary. If you don't want the label 
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to overflow into an adjacent blank cell, select the adjacent cell and press 
the space bar. The cell now contains a character, even though you can't 
see it, so the label will not run into that cell. The entry bar shows the full 
entry, regardless of the width of the column. 

Usually, a better 
solution is to widen that 
column to hold the label. 
In the top row, place the 
cursor on the dividing line 
between columns A and B 
and drag to the right to 
widen column A enough. 
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Whenever you start an entry with a double quote, AtariWorks stores the 
entry as a label. The quotation mark is a signal to AtariWorks that you're typing 
a label. The double quote appears in the entry bar, but will not appear in the 
cell. If you need a double quote to appear as the first character in a label, begin 
the entry with a double quote and follow it with another double quote or an equal 
sign. 

When AtariWorks encounters a label while performing a calculation, it 
treats that cell as having a value of zero. 

Entering a Number 

To enter an integer or decimal number: 

1. Select a cell. 

2. Type a number. Include a decimal point, if necessary. For a negative 
number, begin with a minus sign. 

3. Click the OK button or press the [Return] key. AtariWorks enters the 
number and displays it in the active cell. 
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To type a number in scientific notation: 

For very large or very small numbers, you can use scientific notation. 
To type a number in scientific notation, type an integer or decimal number, 
followed by an E (upper or lower case, but with no space between) and an 
integer that represents an exponent of 10. For example. typing 4.3E8 
represents 430,000,000. The valid range is from 1 E37 down to 1 E-36. 

Building a Formula 

Formulas '!lake the Spreadsheet a useful tool. Without them, you'd just 
have rows and columns of numbers. Formulas tell AtariWorks what to do with all 
these numbers. 

A formula makes up the content of a cell. When you select a cell, 
AtariWorks displays its content in the entry bar. In the cell itself, AtariWorks 
displays its formaned value. When the selected ceil contains a constant value 
(either text or numbers), the display in the entry bar and in the cell will be the 
same. When the selected cell contains a formula, however, AtariWorks 
calculates it and displays the resulting value in the appropriate format in the cell. 
You can always examine the content of a cell by selecting the cell and looking in 
the entry bar. 

What is the format of a ceil? The format of a cell is different from its 
numeric value. A cell's format determines how the value is displayed; for 
instance, as a decimal, percentage, or in dollars. For more information, see 
Changing Number Formats under FORMATTING AND PRINTING, later in 
this chapter. 

What is a formula? A formula calculates a new value from existing values. 
A formula can consist of numeric values, cell references, operators, and 
functions. A formula can be as simple as B1 +B2, which adds the values in cells 
BI and B2. Or a formula can be complex, like:. Pi ()/2-ATan(BI /Sqrt(I-BI2)). 

With AtariWorks you can use the keyboard to enter your formula or you 
can set up most of a formula by pointing and clicking with the mouse. You can 
point to cells and paste functions without typing. 
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To enter a formula: 

1. Select a cell and press :. 

2. Type the formula In the entry bar. 

3. Click the OK button or press the {Return] key. AtariWorks enters the 
formula in the active cell, and displays the resu~ing value. The formula still 
shows up in the entry bar, so that you can see both the formula and the 
results simultaneously. 

You can set up a simple total of a group of cells by pointing with the 
mouse and clicking. 

Example: to get a total: 

1. Select an empty cell for the total and press -. 

2. Click each cell you want to add that is not a label. (Notice that you 
cannot use a range of cells in this particular case, so do not drag across 
the cells.) AtariWorks inserts addition operators (+) between the cells as 
you dick. 

3. Click the OK button or press the (Return) key. AtariWorks enters the 
formula in the active cell, calculates it, and displays the resulting value. 
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You can also sum a range of numbers with the Sum function. See the Sum 
example at the end of Absolute References, below. 

Using References with Formulas 

In AtariWorks, columns are labeled beginning with columns A through Z 
and then AA, AB, AC and so on. Rows are labeled as 1,2, 3, ... The cell in 
column A, row 1, is referred to as A 1. The number of cells you can fill is 
dependent upon the amount of memory available to you. 

References make formulas flexible. You can use the same value in many 
formulas by entering the value in a cell and referring to that cell in the formulas. 
Then, if you change the value of the cell, AtariWorks recalculates the formulas 
using the new value. 

When you build a formula, you can refer to cells using relative references 
or absolute references. 

Relative References 

A relative reference gives general directions relative to the current cell, 
rather than a specific location. It's like saying "Go up two cells and over one to 
the right." If you copy a relative reference to another cell, the reference changes 
relative to its new position. For example, if a relative reference in a formula 
points two rows up and one column to the right, and you copy the formula to 
another location, it still points two rows up and one column to the right, but it 
points to a different cell than it did originally. 

Absolute References 

An absolute reference is different. It refers to a specific cell by its absolute 
location at the time the reference is made. No matter where you copy the 
reference to , it still points to the same cell. For example, an absolute reference 
to cell 81 always points to cell 81, even if the formula containing the reference 
is copied to another location in the spreadsheet document. AtariWorks uses 
dollar signs to indicate that a reference is absolute. $8$1 is an absolute 
reference to cell B1. 
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The difference between relative and absolute references is important only 
when you cut or copy a formula from one cell and paste it into another or when 
you use the Fill Right or Fill Down command. For information on copying 
references, see Copying Cells under Working With the Spreadsheet later in 
this chapter. 

To enter a formula using a reference: 

You can enter a cell reference in a formula either by clicking the 
mouse or by typing. When you use the mouse, AtariWorks puts the 
reference into the entry bar for you. 

1 . Select a cell and press =. 
2. Click the cell that you want to refer to, or type the cell reference. 

You can refer to as many cells as the formula needs. If you do not type an 
operator in the formula before you select each cell after the first one, AtariWorks 
supplies the addition operator (+) . For example, if you type an equal sign, then 
click two cells, AtariWorks adds the contents of the two cells. 

You can also refer to a range (or block) of cells with one reference. The 
reference includes the beginning reference, a colon standing for to, and the 
ending reference. For example, the range reference A2:85 refers to all the cells 
from A2 to 85 inclusive. You can use range references only in certain functions : 
for example, Sum (C4:E10). 

To enter a range reference in a formula : 

1. Select a cell. 

2. Type a reference for a range of cells. 
·-or--

2. Just click on the first cell in the cell range you want and drag to the 
last cell in the range. 

To enter an absolute reference: 

You can create absolute references by typing dollar signs before the 
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column letter and row number. You can also use the (ControlJl(ShiftJI 
[Alternate] keys while clicking the mouse to change the cell reference to 
absolute. It is dynamic. If you switch between [Control], [Shift] and 
[Alternate) keys while the mouse button is pressed, the type of absolute 
reference changes. If no key is pressed it is a relative reference. 

Mixing References 

If you want to refer to cells in such a way that only the column or the row 
reference is absolute (or relative) , you can use mixed references. For example, 
in the reference $83, only the column reference (column B) is absolute. 

Operators 

An operator is an instruction, such as + or -, that tells AtariWorks to 
calculate a new value from existing values. For example , in the formula =3+6, 
the addition sign (+) is the operator that instructs AtariWorks to add the 
operands 3 and 6 to produce the new value 9. AtariWorks uses two kinds of 
operators: arithmetics and comparisons. 

Arithmetic Operators 

The arithmetic operators represent standard calculator functions. These 
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include 

+ Addition - Subtraction 

• 
Negation (if used with one operand only) 
Multiplication 

I Division 
Exponentiation 

To USB an arithmetic operator: 

,. Select a cell. 

2. Type the first number or click a cell reference. 
3. Type an arithmetic operator. 

4. Type the second number or click a cell reference. 

5. Type as many additional numbers and operators as you need. 

6. Click the OK button or press the [Return] key. AtariWorks enters the 
formula in the active cell, calculates it, and displays the resulting value. 

Remember that if you don't type an operator after an operand (number or 
cell reference) in a formula, AtariWorks automatically inserts an addition sign (+) 
before the next cell reference when selected. 

Comparison Operators 

A comparison operator compares two values and produces the value 1 
(TRUE) or 0 (FALSE). AtariWorks has six comparison operators: 

; Equals 
< Less than 
<; Less than or equal to 
> Greater than 
>- Greater than or equal to 
<> Not equal to 

Chapter 5: The Spreadsheet 5-14 



For example, 3<2 produces the value a (FALSE), while 2<3 produces the 
value 1 (TRUE). If cell 817 oontains 5 and cell 852 oontains 13, then 817>852 
produces 0 (FALSE) and 817<852 produces 1 (TRUE). 

Order of Operators 

If you oombine several operators in a single formula, AtariWorks performs 
the operations in this order: 

, Exponentiation 
Negation 

* and I Multiplication and division 
+ and - Addition and subtraction 
'" < <= > >= <> Comparison operators 

If two operators of the same level are encountered, their order of 
evaluation is left to right. 

If you want to change this order, use parentheses. AtariWorks first 
calculates the expressions in parentheses, and then uses those results to 
calculate the rest of the formula. For example: 

Without parentheses: 4*3+2::1: 14; -3"2 --9 

With parentheses: 4*(3+2) '" 20; (-3)"2 - 9 

Functions 

A function is a built-in calculation. A function is similar to an arithmetic 
operator, such as + or -, in that it produces a new value from other values, 
called arguments. 

AtariWorks has 53 built-in functions that you can paste or type into 
formulas. For a detailed description of each function, see Appendix A, 
Spreadsheet Functions. 

Parts of a function: Each function consists of the function name, a set of 
parentheses, and arguments (the values the function uses to produce a new 
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value) separated by commas. 

Arguments to functions: In AtariWorks an argument to a function can be a 
number, a reference, a range reference, another function, or an expression 
such as C3/2. You can click cells to insert references into the arguments of a 
function . 

The parentheses are very important. They tell AtariWorks where the 
arguments begin and end. When you paste a function using the Paste 
Function command from the Edit menu, AtariWorks provides the parentheses 
and positions the insertion point between them. All you do is type the arguments 
and the commas. 

If you type the function instead of pasting it, remember to type the 
parentheses. Be sure to finish with a right parenthesis ; otherwise, AtariWorks 
won't accept the formula. 

Many functions have more than one argument. For example, Average (F1 , 
F2, F3, F4, FS) calculates the average value of cells F1 through F5. It uses a 
series of references to find an average. Pmt (0.0167,36,12000) calculates the 
amount you'd have to pay back on a loan of $12,000 over a period of 36 months 
at 1.67% interest per month. 

To enter a function into a formula: 

You can include functions in a formula either by typing them or 
pasting them. To paste a function into a formula in the entry bar: 

1 . Select the cell to hold the formula. 

2. Position the insertion point where you want the function to go in the 
formula. 

3. Choose Paste Function from the Edit menu. 

4. Click the function you want from the list. AtariWorks pastes the 
function into your formula, including the parentheses. The insertion point 
is inside the parentheses, ready to accept arguments to the function . 
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5. Type any values or click any cell references required by the function. 

6. Include any additional operators and operands that you need in your 
formula. 

7. Click the OK bunon or press the (Return) key. AtariWorks enters the 
formula in the active cell, calculates it, and displays the resulting value. 

If you choose to type a function rather than paste it. be sure to include 
parentheses before and after the arguments. 

Avoiding Circular References 

To help AtariWorks perform as efficiently as possible, avoid circular 
references in your formulas. A circular reference in a spreadsheet document is 
a reference that refers to a cell which in turn refers back to the original cell. 
More specifically, a circular reference occurs when, in order to calculate a 
formula in a part icular cell, AtariWorks needs the value of the same cell that 
contains the formula. An example of such a reference is the formula ",Sum 
(A 1 :AS) when entered in cell A 1. Because a circular reference is a reference 
that has no ending point, the cells involved in a circular reference cannot be 
calculated. When AtariWorks encounters a circular reference it displays an error 
message. 

A more common example of a circular reference involves a chain of cells 
and references. For example, a formula in cell El may refer to cell E2. which 
contains a reference to cell E3. which contains a reference to cell E4, which 
contains a reference back to cell E 1. A circular reference like this cannot be 
resolved . 
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WORKING WITH THE SPREADSHEET 

Aher you've set up a spreadsheet document, you're ready to start playing 
with the numbers to see the results of various scenarios. This section shows 
you ways you can work with a completed Spreadsheet document. 

This section shows you how to: 

• Play What If .. . ? You can change the content of a cell to see the effect 
that change has on the rest of your information. 

• Choose when to recalculate , rather than having AtariWorks do it 
automatically. 

• Display formulas to help analyze the design of a spreadsheet document. 

• Find a cell anywhere in a spreadsheet document. 

• Work with blocks of celis, copying, pasting, turning rows into columns 
and back, filling empty celis, and moving. 

• Sort a spreadsheet document. 

• Insert blank rows and columns. 

These tasks help you analyze the information in your spreadsheet. 

Changing the Content of a Cell 

One of the Spreadsheet's most important assets is its ability to recalculate 
whenever you make a change. Each time you make a change, you play "What 
If?" What if the rate on your building loan goes up by 2%? What if it goes up 
5%? 

As long as you've saved your original spreadsheet document on disk, 
you're working with a copy. None of the changes you try are permanent unless 
you want them to be. On the other hand, if you find several alternative scenarios 
that you 'd like to keep, you can print each one or save each one with a different 
name. 
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You can change the entire content of a cell by selecting the cell and typing 
the new information. The new information replaces the old. Or you can change 
part of a cell's formula or constant value in the entry bar. To do this, just click in 
the entry bar and type the information you wanllo add. 

When you are done making changes, click the OK button (or press the 
[Return] key) to enter the new information into the cell. If you decide not to keep 
your changes, click the Cancel box. AtariWorks restores the previous contents 
of the entry bar. 

Controlling Recalculation 

The AtariWorks Spreadsheet normally calculates automatically whenever 
you enter or change a value. Each recalculation takes some time. You should 
not use numbers displayed on the screen until calculations are complete, since 
the numbers may change as a result of the calculations. 

If you have many numbers to enter and don 't want recalculations to be 
performed until you are finished, you can switch to manual calculation. With 
manual calculation, you tell AtariWorks when you are ready to recalculate. 

To set manual calculation: 

Choose Manual Calculation from the Option menu. Then, when 
you've entered all your information and are ready to recalculate manually, 
choose Calculate Now from the Option menu. (You may also use the 
Control-E keyboard combination.) 

To return to automatic calculation: 

If you no longer have many changes to make, you can switch back to 
automatic calculation. Choose Auto Calculation from the Option menu. 

When you're examining the effects of changes to a single cell , automatic 
calculation saves you the trouble of repeatedly telling the Spreadsheet to 
recalculate. 
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Showing Formulas or Values 

The Spreadsheet usually displays in its cells the values that result from 
calculations. The entry bar displays the content of a single, active cell. But 
sometimes you may want to see all the formulas in a spreadsheet document, so 
you can figure out the logic behind its design. 

To show formulas: 

To have AtariWorks display all the formulas and un-formatted values, 
choose Show Formula from the Option menu. 

For analyzing numbers, it's better to look al values than formulas. To 
have AtariWorks display values, choose Show Value from the Option 
menu. 

Finding a Cell 

If you want to look at a celilhat's just beyond the edge of the window, you 
can find it easily by scrolling. But a cell that's far away on a very large 
spreadsheet document may be difficult to lind. 

If you specify the coordinates of a cell . AtariWorks will find it for you. If you 
know only what's in the cell . you can specify its value. and AtariWorks will try to 
lind a cell that matches what you type. AtariWorks can also take you to the first 
cell (press [Cir Home). lind the last active cell (see below). or take you to the 
last cell (press [Shift)-[Cir Home1) in a spreadsheet document. 

Two commands from the Select menu will allow you to find a particular 
cell: Find Cell and Go To Cell. Use Find Cell to have AtariWorks select a 
particular cell. and use Go To Cell when you just want to see the value 01 a cell . 
but do not want to select it. Note that the keyboard combination ([Conlrol]-F or 
~Control)-G . respectively) is displayed at the right 01 the menu option for these 
commands. 

With the Find Cell command. you can find and select a cell by specifying 
its reference or value. If the value you're looking for is text . you can specify a 
portion of the text and AtariWorks will look for the cell containing it. 
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To find and select a cell: 

1. Choose Find Cell from the Select menu. (You may also use the 
[ControIJ-F keyboard combination.) 

2. Type the reference or the value, or the text of the cell you're looking 
for, in the Find Cell dialog box. 

3. Click the Find Next button. 

If you type a reference, AtariWorks moves to the cell and selects it. If you 
type the cell value, AtariWorks looks for a cell whose value matches what you 
typed. If it finds a match, AtariWorks moves to and selects the cell. If AtariWorks 
can't find anything to match the text you typed, it displays an alert box. 

With the Go To Cell command, you can do exactly the same thing as in 
Find Cell without changing the active cell. 

To find a cefl without selecting it: 

1. Choose Go To Cell from the Select menu. (You may also use the 
[ControIJ-G keyboard combination.) 

2. Type the reference of the cell you're looking for in the Go To Cell 
dialog box. 

3. Click the OK button. AtariWorks moves to the cell but does not select 
it. 

Finding an Active Cell 

The Show Active Cell command from the Select menu help you move 
quickly around a spreadsheet document. " you have been scrolling all around 
the document looking at various cells, the Show Active Cell command takes 
you back to where you were last working. 

To scroll to the currently selected cell, choose Show Active Cell from the 
Select menu. AtariWorks scrolls to the active cell. 
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Copying Cells 

It doesn't take long to type the content of a cell. But there's no real need to 
type the same thing over and over again. With AtariWorks, you don't have to. 
Using commands from the Edit menu, you can copy the content of a cell. For 
example, if you have sales projections for four quarters, you can set up the 
formulas for Ihe first quarter and then copy them for the rest. 

What Happens When You Copy References? 

When you copy and paste a formula that contains relative references, the 
references are adjusted to reflect their new locations. If you copy and paste a 
formula containing a relative reference that refers up two rows and over one 
column, the adjusted reference will refer up two and over one to whatever new 
cell holds that relative position. For example, if the formula in cell C7 is '" C4 
and you copy it to cell 07. AtariWorks changes the formula to '" 04 so that it still 
refers to the cell three up from the formula cell. In this kind of situation, copying 
can be lIery helpful as long as the structure of the spreadsheet requires these 
parallel, relatill8 references. 

When you paste relatille references, the new references look different from 
the old ones, and refer to different cells. Howeller, a copy of an absolute 
reference refers to exactly the same cell as the original reference. Both of these 
occurrences can serve you well in parallel construction, but they also can cause 
problems if you don't want parallel constructions in your spreadsheet document. 

Copying and Pasting Values and Formulas 

When you copy, AtariWorks places a copy of the selected cells onto the 
Clipboard for you to paste somewhere else. 

To copy and paste a selection: 

1. Select the area you want to copy. 

2. Choose Copy from the Edit menu (or press (ControIJ-C). AtariWorks 
puts the selection onto the Clipboard. You can paste multiple copies of the 
same item. 

Chapter 5: The Spreadsheet 5-22 



3. Click the upper-left cell of the area you want to paste into. 

4. Choose Paste (or press [Cantrall-V) from the Edit menu. AtariWorks 
pastes the full contents of the Clipboard back into the spreadsheet 
document, adjusting relative references to reflect their new locations. 

Pasting Values Only 

Sometimes you will want to paste just resulting values, without the 
formulas. The Paste with Option ... command lets you choose to paste just 
values from the Clipboard back into a spreadsheet document. For example, if 
you have an accounts receivable ledger in one spreadsheet document and a 
general ledger in another, you could paste just the total of the accounts 
receivable (that is, values only) to the general ledger. You don't want to paste 
the formulas that produce the values, however, since those would produce 
different values in the general ledger. 

To paste values only: 

1. Select the area you want to copy, and choose Copy from the Edit 
menu (or press (Cantrall-C). 

2. Click the upper-left cell of the area you want to paste into. 

3. Choose Paste with Options ... from the Edit menu. 

4. Click the Values Only option. 

5. Click the OK button. 

Transposing Rows and Columns 

You might want to turn a column into a row if you want to plot that column 
as a bar chart. Or you might want to turn a row into a column so you can make 
a pie chart out of it. Transposing rows and columns is also useful for converting 
records and fields that you copy from the Database. For information about 
copying information from the Database, see the last Chapter of this manual , 
Using the Tools Together. 
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To transpose: 

1. Cut or copy a selection to the Clipboard. The selection can be a 
single row or column or any range of cells. (You may also use the 
(Control]-X or [Control]-C keyboard combinations.) 

2. Click the upper-left cell of the area you want to paste into. This cell 
can be in the same spreadsheet document or you can move to another 
one. 

3. Choose Paste with Options ... from the Edit menu. 

4. Click the Transpose option and choose whether you want to paste 
values only or values and formulas. 

5. Click the OK button. AtariWorks transposes the rows into columns or 
vice versa, then adjusts relative references to reflect their new locations. 

Filing into Adjacent Cells 

Filling lets you copy the content of a row or column into adjacent rows or 
columns. Within a selection, you fill cells to the right of the first column of the 
selection or below the first row of the selection. Filling fills in all cells within the 
selection, replacing their content if they are not blank, so you should be sure 
that any cells containing information can be replaced. 

To fiJI into adjacent cells: 

1. Drag across one column or row containing the data you want to copy 
and as many blank adjacent rows and columns as you want to fill. (Make 
sure the entire block is highlighted.) 

2. Choose Fill Right or Fill Down from the Edit menu. (You may also 
use the (Control]-R or [Control}·O keyboard combinations.) AtariWorks 
copies the contents of the original cells into the adjacent cells. 

If you have any relative references in copied formulas, AtariWorks adjusts 
them relative to their new positions. Absolute references stay as they were. 
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Moving Cells 

Suppose you developed a whole spreadsheet document and then decided 
you wanted your totals at the lOP instead of at the bottom. The Move command 
lets you select a block of cells and move it to a new location within the same 
spreadsheet document. When you move celts, all references in the cells in the 
new location refer to the same cells that they did before you moved them; the 
formulas stili calculate from the same values. AlariWorks adjusts any other 
formulas on the spreadsheet document that conlain references to the moved 
cells, so that they refer to the new location of the moved cells. 

To use the Move command, you must know the coordinates of the cell at 
the upper-left corner of the location you want to move to. 

To move a block of cells: 

1. Choose Move from the Edit menu. 

2. Type the reference of the cell that wi ll contain the upper-left corner of 
the moved selection. AtariWorks will replace the contents of any cells that 
aren't blank, so make sure their contents can be replaced. 

3. Click the OK button. AtariWorks moves the selection from its old 
location and pastes it into the new one. 

All relative references in the moved cells refer to the same cells as they 
referred to before the move. 

Sorting 

You can change the order of rows in a selection by sorting. You might want 
to sort a payroll document in alphabetical order by last names, or you might 
want to son a stock room inventory by pan number. AtariWorks tets you son in 
ascending and descending order. 

If you have numbers and text in the same column, the numbers come first, 
whether you're sorting in ascending or descending order. Blank cells are always 
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sorted last. You can sort on up to three key columns. This allows you to have 
subgroups for subtotals. For example, you could sort a payroll document by 
department, supervisor, and last name, sening up a subtotal for each category. 
That would let you analyze payroll expenses by department and supervisor. 
Sorting affects only selected cells. AtariWorks rearranges the selected cells in 
each row according to the order you specify for the key column. When you 
change the order, most cells will have different cell references. AtariWorks 
changes both absolute and relative references, inside and outside the selection, 
to reflect new cell locations. 

To sort a spreadsheet document: 

1. Select the cells you want to sort. 

2. Choose Sort .•. from the Edit menu. 

3. Type the lener of the column heading on which you want to sort the 
key column. 

4. Click the order you want to sort in (ascending or descending). 

5. If you have a second or third key column, move the insertion point 
into the appropriate box and type the letter. 

6. Click the OK bunon or press the [Return] key. AtariWorks reorders 
your selection. 

Note: You can only sort rows. If you try to sort columns based on key row 
headings, AtariWorks displays an alert box. 

Copying a Spreadsheet Table as a GEM Metafile 

To copy a spreadsheet table as a GEM Metafile, first select the range of cells 
you want to appear as a table. Then select Copy as Metafile from the Edit 
menu. AtariWorks copies the selected block to the clipboard as a GEM Metafile. 
This is useful if you want a part of your spreadsheet to appear as it is in a word 
processor document. 
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Inserting and Deleting Rows or Columns 

You can insert rows or columns in a spreadsheet document whenever 
necessary. $0 if you have just finished a large document after hours of work 
and you discover that you need just one more row, AtariWorks can help you. To 
insert a row or column When you insert rows or columns, both relative and 
absolute references are adjusted accordingly. So if you have a ceil referring to 
cell A 1 and insert a row above row' , the changed reference will be to cell A2, 
one row down. 

To insert a row or column: 

1. Click the row or column heading where you want to insert a new row 
or column. Select the number of rows or columns you want to insert. 

2. Choose Insert Row/Column from the Edit menu or press (ContraIJ-I. 
AtariWorks inserts the new row or column at the selection point, moving 
the selected row beneath the insertion, or the selected column to the right 
of the insertion. All the rows or columns that follow the new one are 
renumbered. 

To insert multiple rows or columns: 

1. Click the row or column heading where you want to insert new rows 
or columns. Select the number of rows or columns you want to insert. 

2. Choose Insert Row/Column from the Edit menu. AtariWorks inserts 
the chosen number of rows or columns, moving the selected row or 
column down or to the right, as above. 

To delete a row or column: 

1. Click the row or column heading that you wish to delete. 

2. Click on Delete Row/Column from the Edit menu or press 
(ControIJ-K. (To merely blank the cells in that row or column, leaving the 
row or column in place, click on Delete instead.) 
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FORMATTING AND PRINTING 

The first two sections of this part of the manual explained how to set up a 
spreadsheet document and to perform calculations with it. In this section, you'll 
learn how to change the way it looks. 
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Untitled (55) (Not Sayed) I 
A B C D E 

SALES SUMMARY, 1993 (000 omitted) 

lQ 2Q 3Q 4Q 
Gross Sales, DomB5ti~ $2,3(6.00 $3076.00 $2,879.00 $1,986.00 
Gross Sales, Foreign $1.1~2.00 $1,816.00 $1,686.00 $1,223.00 
.......... _--_ .. _--_ ... __ ..... _--_ ..... _-_ .... _----_ ... --_ ................. _--_ .... _-_ ... _--_ .. __ .......... 

Total Sales $3,"88.00 $4,892.00 $4,565.00 $3,209.00 

Cost of Sales $2,12!l.00 $2,761.00 $2,466.00 $1,850.00 
Cost as S of Sales 60.78 56." 54..02 57.65 

This section also explains how to print a spreadsheet document when you 
have the format adjusted. 

Read this section to learn how to: 

• Change the way numbers are displayed 

• Realign the content of cells 

• Emphasize cells with bold type or underlining 

• Display or remove the grid 

• Change the column width 

• Protect cells from changes 
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• Set page breaks for printing 

• Print a spreadsheet document 

About Cell Formats 

The value of a cell and how AlariWorks displays thaI value within the cell 
are different. The value of a cell is determined by its formula. How that value is 
displayed is determine(i by the format of the cell. You can change the 
appearance of a spreadsheet document in a variety of ways without affecting 
formulas or values in cells. When you change a cell's format, its value does not 
change; AtariWorks displays Ihe cell's value in the new format. Using 
commands from the Format menu, you can specify the format of a cell after you 
enler Ihe content of the cell. 

Changing Number Formats 

Unless you specify otherwise, AtariWorks displays numbers in General 
format (that is, as accurately as possible, given the cell width). For example, if 
you type 12345.6789, AtariWorks may display it in a variety of ways, depending 
on the width of the cell: 12345.679, 12345.7, 12346, l E+4, and so on. 

Numbers can be displayed in General format, as fixed decimals, dollars, 
percents, or in scientific nolation. With all formats except General, you can set a 
fixed number of decimal places to display. One spreadsheet document can 
conlain many different cell formats. 

To change the format of celfs: 

1 . Select the cells you want to format. 

2. Choose General, Fixed, Dollar, Percent, or Scientific from the Format 
menu. AtariWorks adjusts the format of the selected cells accordingly. 

Unless you specify otherwise, AtariWorks displays two decimal places in 
your numbers in all formats except General. You can choose to display up to 15 
decimal places. 
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To change the number of decimal places: 

1. Select the cells for which you want to change the number of decimal 
places. 

2. Choose No. of Decimals .. . from the Format menu. 

3. Type the number of decimal places you want displayed. 

4. Click the OK button or press the [Return] key. AtariWorks adjusts the 
numbers accordingly. 

Displaying Numbers with Commas 

You can choose to display numbers with or without commas. If you type 
commas into your numbers as you enter them, AtariWorks treats the number as 
text. Because you may not want numbers treated as text, AtariWorks provides 
an alternative, and saves you the trouble of typing in commas. 

To choose whether to show commas: 

1. Select the cells you want to format. 

2. Choose Commas or No Commas from the Format menu. 

Aligning Cell Contents 

Labels automatically line up on the left of the cell and numbers on the right. 
However, you might want to center or right-align your labels, or left-align your 
numbers. So AtariWorks lets you specify the alignment of cells. You can select 
columns, rows, a single cell, or a block of cells to realign. 

To change the alignments of cells: 

1. Select the cell(s) whose alignment you want to change. 

2. Choose Align Left, Align Center, or Align Right from the Format 
menu. AtariWorks adjusts the alignment of the selected cell or cells. 
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Adding Emphasis to Cell Content 

Spreadsheet cells contain normal (plain) type unless you change the type 
with the Format menu. You can add emphasis to the content of any cell by 
changing the style of the cell to Bold, Underlined, or both. Note that there are 
keyboard equivalent commands to the right of each menu option. 

To change the type style of celfs: 

1. Selecl the cells whose type style you want to change. 

2. Choose Bold from the Format menu (or type Control-B), Underline 
(Control-U), or Normal Text (Control-N). AtariWorks changes the type 
style of the selected cells. 

Displaying the Grid 

You can choose whether or not to display the grid. To display the grid, 
choose Show Grid from the Option menu. To remove the grid, choose No 
Grid. 

Changing Column Width 

When something doesn't fit in a cell, you can widen the cell. You can 
change the width of a column by dragging the line at the right of the column 
heading or by choosing Column Width ... from the Format menu. 

To change column width by dragging: 

1. Position the pointer on the right edge of the column heading. 

2. Press and hold the right mouse button. The pointer changes to a 
finger, and you can drag to the right to make the column wider, or drag to 
the left to make the column narrower. 

When you enter a label, if you type more characters than will fit in a cell 
before you've widened it, AtariWorks continues the label into adjacent blank 
cells, jf possible. 
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Using Fonts in Cell Contents 

At the bottom of the Options menu is the Fonts ... option. If you are using 
scalable tonts, as with SpeedoGDOS, you may wish to have the text of your 
spreadsheet document appear as if it were typeset. AtariWorks uses the same 
font for a single document. You can use different fonts for different documents. 

To change fonts: 

1. Click on Fonts ... at the bottom of the Options menu. 

2. From the Fonts dialog box, choose the font by clicking on the font 
selector bar and moving your mouse down the list until the font you want 
is highlighted. Click on the fant. 

3. On the next line, you can type in the size of the font (a range from 1 
point to 144 points is listed at the side of the line). There are blanks for 
three numbers, but you do not need to use all of them. 

4. Once you have the font style and size you want, click on the OK 
bunon or press the [Return] key. 

Protecting Cells from Changes 

When you set up forms for other people to till in, ar if you have important 
formulas that toak a long time to set up, yau probably would like to protect this 
work from being changed. In AtariWorks, you can da this with cell protection. 
Later on, if you need to change the contents of a protected cell, you can remove 
cell protection. You can set protection separately for each cell or range of cells. 

To set cefl protection: 

1. Select the cell ar range of cells you want to protect. 

2. Choose Protected from the Option menu. 

AtariWorks protects the selected cells. You won't be able to type in the 
protected cells unless you remove cell protection. The values in cells with 
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formulas still change, but you won't be able to change the formulas themselves 
until you remove cell protection. 

To remove cell protection: 

1. Select the cell or range of cells whose protection you want to remove. 

2. Choose Not Protected from the Option menu. 

Setting Page Breaks 

In a spreadsheet document, you can set both horizontal and vertical page 
breaks. AtariWorks automatically sets page breaks according to the margins 
you choose in the Page Setup ... command from the File menu. But you may 
want to specify your own page breaks. That's what the Set Page Break 
command is for. 

Printing 

To set a page break: 

1. Select the cell that you want to be at the upper row/left column the 
new page. 

2. Choose Set Page Break from the Option menu. Vertical and 
horizontal dashed lines (page break indicators) show where you've set the 
page break. 

To remove a page break: 

1. Select the cell in the upper-left corner of the page. 

2. Choose Remove Page Break from the Option menu. AtariWorks 
removes the manual page break··both the horizontal and vertical dashed 
lines. 

When you're ready to print a spreadsheet document, you can specify page 
breaks and set up headers and footers to print at the top and bottom of every 
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page. For a detailed explanation of the printing process, including how to fill out 
the necessary dialog boxes, see Printing a Document in Chapter 2. This 
section discusses only items that are specific to printing a spreadsheet 
document. 

When you're ready to print a spreadsheet document, you have two 
options. You can choose to print: 

• All cells through the last cell, or 

• Only selected cells. 

If you use the Print. .. command without selecting more than one cell, 
AtariWorks prints all cells through the last cell. With each of these options, you 
can choose whether or not to print row and column headings. If you want these 
printed, click the Print Rowand Column Numbers option in the Page Setup 
dialog box. 

To print an entire spreadsheet document: 

1. Choose Page Setup ... from the File menu. 

2. Click the appropriate options. 

3. Click the OK button or press the {Return] key. 

4. Choose HeaderfFooter ... from the File menu. 

5. Type any text you want for a header and footer. 

6. Click the OK button or press the [Return] key. 

7. Choose Print ... from the File menu. 

8. Click the appropriate options. 

9. Click the OK bunon or press the [Return) key. AtariWorks prints your 
entire Spreadsheet document. 
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After you press OK, AtariWorks will ask you if you wish to suppress zeros. 
If you click on Yes, your printout will be blank in all cells that have a numeric 
value of zero (except labels). If you choose No, the zeros shown on the screen 
will also appear on your printout. 

If the document is too wide to fit on one page, AtariWorks first prints on 
subsequent pages the remaining columns for Ihe rows that fit on that page, 
before continuing to print the remaining rows. 

To print a range of celfs: 

1 . Select the range of cells you want to print. 

2. Choose Print •.. from the File menu. 

3. Click the appropriate options. 

4. Click the OK button or press the [Return] key. AtariWorks prints just 
the selected range of cells. 

If the selection crosses a page break, AtariWorks prints the selection on two 
pages. 
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CHARTING A SPREADSHEET DOCUMENT 

The Spreadsheet's charting capability can convert information from 
spreadsheet documents into two kinds of charts. Each spreadsheet document 
can have up to 15 chart definitions stored with it. A chart definition consists of 
the information you specify in a dialog box for either a series chart or a pie 
chart. When you're trying out different scenarios in the Spreadsheet, changing 
the numbers or the formulas you use for calculation, the results show up 
immediately on your chart. 

Charts can speed up your analysis of numbers. Relationships that are 
otherwise hard to see show up easily on a chart. You can use information from 
other spreadsheet or database programs to make charts. Just copy the 
information into a AtariWorks spreadsheet document. then you're ready to 
create a chart. 

This section explains how to use the Spreadsheet's charting capability to 
plot the information in your spreadsheet documents. You'll learn how to: 

• Create series charts 

• Create pie charts 

• Work with chart definitions and charts 

AtariWorks can create two types of charts: series charts and pie charts. 
Series charts show relationships between numbers. For example, a series chart 
might illustrate a company's total sales for each of the last four quarters. Pie 
charts help you see proportions of a whole. For example, a pie chart might show 
a breakdown of your expenses as part of an overall budget. 

Series Charts 

This section gives a brief overview of the different kinds of series charts 
and describes how to create them, AtariWorks draws four types of series charts: 
line charts, bar charts, stack charts, and combination (called "combo" in the 
dialog box) charts. Each of these charts gives you a different way of looking at 
the same information. The type of chart you use depends on the information 
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you 're analyzing, or how you want to show it. It's similar to working with an 
artist: you supply the information and explain what kind of chart you want, and 
the artist draws it. Of course, with AtariWorks you can use the same information 
with different types of charts to see quickly which one works best. 

Line and Bar Charts 

Line Charts: A line chart uses a line to link together points that represent 
numbers. When you compare more than one set of numbers, each set of 
numbers has one line. As each line crosses the categories on the horizontal 
axis, it makes the intersection with a distinct symbol called a point marker. Line 
charts are very effective at showing a growth or decline in numbers over lime, a 
relationship called a trend. 

Bar Charts: When you're comparing more than one set of numbers, a bar 
chart groups the numbers by category . Bar charts compare sets of numbers 
divided into discrete categories. Use bar charts when it's important to compare 
numbers within a category of numbers. 

Stack and Combination Charts 

Stack Charts: Stack charts are a variation on bar charts. Stack charts 
illustrate component parts of a total as they change. A regular bar chart doesn't 
show these amounts added up, so although you see how the amounts compare, 
you don't see their total. 

Combination Charts: Combination charts combine a bar chart with a line 
chart. Use combination charts when you want to see one set of numbers (with 
bars) and the trend of another set of numbers(with a line) at the same time. 

Creating a Series Chart 

To create a series chart, set up a chan definition for a series chan by using 
the Chart Definition dialog box. In this dialog box, you provide all the information 
AtariWorks needs to draw a series chart of your spreadsheet data. You specify 
the chan type, a chan title, titles for the venical and horizontal scales, the 
headings of the column and rows to be charted and ta be used far the data 
legend and the horizontal titles, and the vertical scale of the chart .To see the 
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Chart Definition dialog box, choose New Series .•• from the Chart menu. This 
takes you directly to a new Chart Definition dialog box. You can put a title on the 
chart itself by typing it in the Chart Title box. If you don't specify a title, 
AtariWorks will plot the chart with the title "Untitled." 
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The four icons in the upper-left corner of the Series Chart dialog box let 
you choose between a line chart, a bar chart, a stack chart, or a combination 
(combo) chart. To choose a chart type, click the icon that represents the type of 
chart you want to make. If you aren't sure what type you want, review the 
descriptions at the beginning of this section, or just choose a type to experiment 
with. You can easily change to another type later. 

You can also specify titles for the horizontal and vertical scales of the 
chart. Scale titles help to explain the units of information shown on the scales. If 
you don't type scale titles in the text boxes, AtariWorks will not show any vertical 
and horizontal scale titles. To specify titles for the scales, type titles in the 
Vertical Scale Title and Horizontal Scale Title text boxes in the Series Cha'1 
dialog box. When you plot the chart, these titles appear on the chart itself. 
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Numbers define a chart, telling AtariWorks how high to make a bar or 
where to put a point on the scale. The numbers that define a chart are in the 
rows and columns of your spreadsheet document. AtariWorks lets you plot up to 
four sets of information in a series chart. That means you can choose up to four 
rows from a spreadsheet document for charting. 

To specify the rows and columns that you want to chart: 

1. In the Values to be Plotted boxes, type the headings (numbers) of the 
rows that contain the values you want to chart from the spreadsheet 
document. If the data you want to chart is in columns, you'll need to 
transpose it into rows before charting. Activate the spreadsheet document 
and use the Copy and Paste with Options commands from the Edit 
menu. 

2. In the From Column and To Column boxes, type the headings of the 
columns which begin and end the information you want in the rows you 
specified in step 1. 

AtariWorks will chart numbers in the specified rows from the beginning 
column to the ending column. 

Note: The columns must be adjacent to one another. 

Labels help you identify your numbers. Your spreadsheet row labels (the 
text that describes the information in the rows) become the data legend. The 
data legend describes the sets of information in the chart. Your spreadsheet 
column labels become titles for the horizontal axis. AtariWorks calls these 
horizontal titles. 

To specify a data legend and horizontallitles: 

1. In the Data Legends in Column box, type the heading of the column 
containing the label(s) for the row(s) of information you're charting. The 
data legend will appear at the bottom of the chart, and will identify the 
shading patterns used for each bar in a bar chart, or the shape of the point 
marker used for each line in a line chart. 
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2. In the Horizontal Titles in Row box, type the heading of the row 
containing the labels for the columns that you're charting. These labels will 
appear along the horizontal scale 10 label each bar in a bar chart or each 
point in a line chart. (If you are charting many columns, there may not be 
room for every label on the chart). 

Setting the Vertical Scale 

You can choose to have a numeric scale or semilogarithmic scale for the 
chart. A numeric scale is divided into ten regular increments (10, 20, 30, 
40, ... 100, for example). 

A semilogarithmic scale exaggerates the size of smaller numbers and 
minimizes the size of larger numbers. Such a scale makes it easier to show very 
large numbers and very small numbers on the same chart. You can also choose 
to limit the chart to a certain range, between a minimum and a maximum. You 
might want to do this if all your amounts were greater than a certain amount, like 
a million, or less than a certain amount, like two million, or between two 
amounts. If your minimum were one million and your maximum two million, you 
could use the fult range of the chart to see the numbers between those two 
figures. Setting a maximum can also make a chart with a numeric scale easier 
to read. 

When you choose a numeric scale, AtariWorks uses the largest number in 
the chart as the top of the scale. AtariWorks divides the scale into ten 
segments. To establish more standard divisions, you can set a maximum that is 
a multiple of ten. 

To set the vertical scale: 

1. In the New Series Chart dialog box, click Numeric or 
Semilogarlthmic for the vertical scale. 

A grid helps you see where points on the chart line up on the scales. 
Labels (titles) help you identify what the numbers mean. You can choose 
whether a chart wilt show the grid or the labels. To show Ihe grid or labels, if 
they are not already checked in the New Series Chart dialog box: 
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• Click the Draw Grid option. 
--0(--

• Click the Label Chart option. 

If the options are checked already, and you do not want either a grid or the 
labels on your chart, click to ignore them. 

Plotting the Chart 

After you've filled out the dialog box, you can take any of the following 
actions. 

To plot the chart. click the Plot It I button. AtariWorks draws the chart and 
stores the definition with the spreadsheet document. 
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To return to the spreadsheet document without storing the chart definition 
or drawing the chart, click the Cancel button. 

If you want to continue working with your series chart before you begin to 
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learn about pie charts, skip ahead in this section to Worktng with Charts and 
Chart Dellnilions. 

Pie Charts 

This section explains when to use pie charts, what pie charts show, and 
how to create Ihem. 

When to Use a Pie Chart 

Pie charts compare parts of a whole. For example, a pie chart can illustrate 
which parts of a company's budget are allocated to production, marketing, 
development, and overhead. Pie charts compare only one set of information. 
dividing it into parts of a total, represented by the whole pie. In a spreadsheet 
document, this corresponds to one column of numbers. A column of labels 
provides the key for each slice of the pie. AtariWorks calls these labels value 
titles. 

If you have a spreadsheet document with several columns of information 
that you want to chart as a pie chart, you will have to define a pie chart for each 
column. Each of the pie chart definitions will be stored with your spreadsheet 
document, so that you can look at them at any time. 

Creating a Pie Chart 

To set up a chart definition for a pie chart, you use the Pie Chart Definition 
dialog box. In this dialog box, you specify the column containing the values you 
want to plot, the beginning and ending row headings, and the column containing 
the labels for the value titles. 

To see the Pie Chart Definition dialog box: 

1. Select New Pie .•• or Select ... from the Chart menu. 

2. Choosing New Pie Chart takes you directly to a Pie Chart Definition 
dialog box. 

3. Choosing Select Definition gives you the Select Chart dialog box. 
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Select a chan definition name and click the OK button to see the Chan 
Definition dialog box. 

You can put a title on the chart itself by typing it in the Chart Title box of 
the Pie Chart Definition dialog box. If you don't specify a title, AtariWorks will 
plot the chart without any title. 

To specify a chart title , type a title for the chart in the Chart Title box. When 
you plot the chart, this title appears directly above the chart. 

When you define a pie chart, you need to tell AtariWorks what values to 
plot. Fill in the rest of the New Pie Chart dialog box to indicate which values you 
want to plot and which value titles you want to use. 

Exploded Pie: You can also explode a sector of the pie chart if you wish. 
Thus, you can make a particular item more emphatic than the others. 
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Plotting the Chart 

After you've filled out the dialog box, you can take either of the following 
actions. 

To plot the chart, click the Plot It! button. AtariWorks draws the chart and 
stores the definition with the spreadsheet document: 

~o.... .. ti< 117 .2S'" 

~F_"... n ., •• 

To return to the spreadsheet document without storing the chart definition 
or drawing the chart, click the Cancel button. 

Working with Charts and Chart Definitions 

Once you've set up a chart definition for either a series chart or a pie chart, 
you can continue to work with it. You can: 

• Change the name of a chart definition . 

• Select either a chart or a chart definition to look at again. 
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• Change a chart by changing information in the spreadsheet document or 
by changing its definition . 

• Copy or remove chart definitions from a Spreadsheet document. 

Changing Chart Definition Names 

The liUe bar of a chart definition dialog box shows the name of the chart 
definition. When you set up several chart definitions for a single spreadsheet 
document, you'll be able to identify each one by name. Unless you specify a 
name with the Edit menu as described below, AtariWorks automatically names 
each chart definition with the name of the spreadsheet document plus the word 
"Chart" and a number from 1 to 5. 

Selecting a Chart 

After you've defined a chart, you can choose to draw it directly from the 
Chart menu. You don't have to set up a new definition every time you want to 
chart something. Here's how to draw a chart quickly: 

1. Choose Draw •• , from the Chart menu. AtariWorks displays a dialog 
box listing the chart definition(s) stored with the active spreadsheet 
document. 

2. Select the chart you want to see. 

3. Click the OK button or press the [Return] key. AtariWorks draws the 
chart. 

Selecting a Chart Definition 

II you've set up a chart definition, you might want to look it over or make 
changes. You can move to a chart definition dialog box from the Chart menu 
when you're working in the Spreadsheet: 

,. Choose Select. .. from Ihe Chart menu. AtariWorks displays a dialog 
box listing the chart definitions stored with the active spreadsheet 
document. 
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2. Select the definition you want to see. 

3. Click the OK button or press the [Return] key. AtariWorks opens the 
dialog box containing the definition you specified. 

You may find that you need to change something about a chart. You can 
change the actual contents of a spreadsheet document and see those changes 
reflected immediately in the chart. Or you can change the chart definition, the 
information you want to chart, the type of chart, the titles on the chart, or the 
scale. You can work on a spreadsheet document and a chart at the same time, 
as you analyze your information. If you're making projections or comparing 
alternatives, you see graphically how alternative numbers or calculations aHect 
your results, without waiting, because the chart is linked directly to the 
spreadsheet document. 

To change spreadsheet information while charting: 

1. Click anywhere in the Spreadsheet window to activate it. 

2. Select the cells you want to change and make the changes. As you 
enter the changes in the spreadsheet document, the chart will reflect 
them. 

The chart definition tells AtariWorks what information to plot and where to 
put it. You can change a chart definition whenever you want. 

To change a chart definition: 

1. Open a chart definition dialog box. You can do this from the Chart 
menu. 

2. Change the appropriate information in the definition. 

3. Click Plot It! to see the changed chart, save the changes to the 
definition and discard the original definition. 
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Copying a Chart Definit ion 

AtariWorks lets you make a copy of a chart definition. Then you can make 
changes to the copy without changing the original. You'll find this useful if you 
need to make several similar charts from the same spreadsheet document. 

To copy a chan definition: 

1. Choose Duplicate" . from the Chart menu. AtariWorks displays a 
dialog box listing the chart definitions stored with the active spreadsheet 
document. 

2. Select the definition you want. 

3. Click the OK button or press the [Return] key. The chart definition 
dialog box appears. You can change the title of the chart and its 
characteristics. 

When you click Plot It! , you store the new definition with the spreadsheet 
document. The original definition remains stored unless you decide to remove it. 

Removing a Chart Definition 

Suppose you decide you no longer need a chart, or accidentally make a 
chart you don't want. Or perhaps you already have reached the limit of fifteen 
definitions, and you want to make a new one. You can remove a chart definition 
you don't want to make room tor another. 

To remove a chart definition: 

1. Choose Erase ... from the Chart menu. AtariWorks displays a dialog ' 
box listing the chart definitions stored with the active spreadsheet 
document. 

2. Select the definition you want to remove. 

3. Click the OK bunon or press the [Return] key. AtariWorks removes 
the chart definition. 
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Viewing More Than One Chart at the Same Time 

You can have more than one chart for a spreadsheet document on the 
screen simultaneously and compare them. You can also have two or more 
charts of same or different spreadsheet documents open at the same time in 
different documents. Just set different definitions and plot the charts in different 
windows. Now resize and place them side by side and you are ready to 
compare the results. Now change your numbers in the spreadsheet window and 
see how they reflect in different windows. 

Saving Charts as GEM Metafiles 

Choose Save from the File menu when the chart window is active. 
AtariWorks shows the Files Selector box. Give the chart a fi lename and click 
OK. AtariWorks saves the chart as a GEM Metafile to the disk. You can now 
import the file into the Word Processor or into any other application of your 
choice. 
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USING THE TOOLS TOGETHER 

AtariWorks is more than three separate tools. While each tool helps you in 
one area of your work. the tools can also work together to perform additional 
tasks they can't perform alone. The Word Processor is ideal for writing, and with 
information from the patabase you can also use it to make business forms, 
customized leners, and mailing labels. You can copy Database figures to the 
Spreadsheet, and you can include Spreadsheet figures in Database documents. 
You can also copy Spreadsheet information, including charts, to the Word 
Processor. Then you can use the Word Processor's special type styles and 
other features to make the information more attractive. 

This part of the manual explains how to use the AtariWorks tools together: 

• Moving Information Among the Tools tells you how to move 
information and pictures among the three AtariWorks tools. It also explains how 
to move charts from the Spreadsheet into the Word Processor . 

• Merging : Creating Mailing Labels, Form Letters, and Forms shows 
you how to use the Database to create form leners and mailing labels, to 
address envelopes, and to fill in forms you create in the Word Processor. 

A Note About Memory Usage 

Copying information among tools is subject to available memory, 
particularly if you are copying large selections. When you copy information to 
the Clipboard and paste the Clipboard's contents, you paste a copy of the 
Clipboard's contents, increasing memory usage by the amount you copy. 

The procedures in this section discuss moving information in terms of 
copying from one tool to another. You can also move information by cuning it 
out of a document. This process works exactly the same as copying, except that 
the information is deleted from the original document. If this is what you want, 
substitute the Cut command for the Copy command in any of these procedures. 
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MOVING INFORMATION AMONG THE TOOLS 

This section explains how to move information among the AtariWorks 
tools. You'Ulearn how to: 

• Copy information to the Word Processor 

• Copy Word Processor information to the Database or Spreadsheet 

• Copy Database information to the Spreadsheet 

• Copy Spreadsheet information to the Database 

• Add finishing touches and edit pictures 

Copying Information Among Tools 

Copying information among the AtariWorks tools is easy. Just open the 
documents you need; the rest is as simple as pointing and clicking. Select the 
information, copy it to the Clipboard, and paste it at its destination. 

You can copy information from open documents only. Depending on 
document size and available memory. you can have up to seven document 
windows open at a time. This makes integrating your information that much 
easier. 

To copy information among the tools: 

1. Make sure that the file from which you want to copy is open. 

2. If necessary, activate the document you want to copy from by 
choosing its name from the Window menu or clicking on the particular 
window. 
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3. Select (highlight) the information you want to copy: 

4. Choose Copy from the Edit menu. 

5. Open the file you want to paste into: 

Herets the first tut It the weir's slies by qUlrter : 

6a. To copy into the Word Processor, position the insertion point in a 
blank line or select the text that you want to paste over (scroll if 
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necessary). If you select text, AtariWorks replaces it with the contents of 
the Clipboard: 

Here's the first ~ut at the year's sal~s by quarter: 

Domestie 
Foreign 

SALES SUMMARY. 1993 (OOOomiu.adJ 
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2Q 
$3076.00 
$1816.00 

3Q 
$2879.00 
$1686.00 

.Q 
$1986.00 
$1223.00 

6b. To copy into the Database or Spreadsheet, select the entry or cell at 
the upper-left corner of the area you want to paste into. You can also 
select a range of entries or cells as the paste area: 
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7. Choose Paste from the Edit menu. AtariWorks pastes the copied 
information: 

As long as the information remains on the Clipboard, you can paste the 
information as many times as you want. For example, to use the same chart at 
the beginning of each section of a document, you can copy it once from the 
Spreadsheet, then scroll through your document, pasting a copy of it each time 
you come to a new section. 

Copying Information to the Word Processor 

When you select information to copy to the Word Processor, you need to 
consider how it will look in a Word Processor document. Your selection may be 
longer than a single page, or wider than a standard page. AtariWorks divides 
selections longer than a page into page-sized pieces for the Word Processor. If 
Database records or Spreadsheet rows are wider than a Word Processor page, 
AtariWorks formats your information to fit while you paste it in . 

You can copy information from one Word Processor document to another. 
Just use the general procedure described above. Notice that if you position the 
insertion point in a blank line, AtariWorks automatically opens up enough space 
to paste the entire contents of the Clipboard. 
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Before you copy a chart to the Word Processor, you should insert enough 
blank space for the chart, and the surrounding white space that gets copied with 
it. by inserting return characters. Otherwise. the chart will be pasted over 
existing text. 

Note: If you do paste the chart over text, you'll see the chart overlaid on the 
text. Position the insertion point at the beginning of the first line of the covered 
text, and press (Return1 repeatedly until the text scrolls out from under the chart. 
Alternatively, you can move the chart. If you want to indent the chart from the 
left margin, press the [Tab] key or space bar to position the insertion point 
where you want it. AtariWorks pastes the chart below and to the right of the 
insertion point. Once the chart is pasted into the Word Processor, you can treat 
the chart as a picture. For more information, see Editing Pictures later in this 
section. 

Copying Spreadsheet Information to the Word Processor 

When you copy Spreadsheet information to the Word Processor, each 
column arrives separated by a tab character. Each row ends with a return 
character. If the rows are wider than the Word Processor page, AtariWorks 
formats the information while you paste it in. 

Spreadsheet information is always pasted in the font style and size used 
by the Spreadsheet, but you can change the font and type size once the 
information is in the Word Processor. 

When you copy Spreadsheet numbers or formulas to the Word Processor, 
AtariWorks pastes them as text. The relationship among the cells in the 
Spreadsheet no longer exists. For example, if you change a number in a ~olumn 
copied to the Word Processor, the total for that column will not change. You 
need to select the total as text and change it by using the standard Word 
Processor editing techniques. 

You may want to adjust tab stops to change the appearance of the 
columns. For more information, see the section on Setting and Using Tabs in 
the Word Processor chapter. 
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Copying Database Information to the Word Processor 

When you copy records from the Database. each field arrives separated by 
a tab character. Each record follows on its own line, ending with a return 
character. Records that are wider than the Word Processor page can be 
selected and formatted to fit after you paste. 

Database information is always pasted in the font style and size used by 
the database, but you can change the font or type size once the information is in 
the Word Processor. 

Copying Information to the Database or the Spreadsheet 

AtariWorks copies information to the Database and Spreadsheet in the 
same way. Each entry or cell contents ends with a tab character to indicate the 
end of a field or column, and each record or row ends with a return character. 
This section explains how to copy information to these tools, using spaces, tab 
characters, andlor return characters to keep the information in its characteristic 
columns and rows. 

Copying Information from the Word Processor 

You may have information in a word processor document that you want to 
copy to the Database or Spreadsheet. You can copy the information as you 
normally WOUld, but you need to tell AtariWorks how to distinguish between 
fields and records or columns and rows. Each piece of information that will go 
into a field or cell should be separated from the next piece by a tab character. 
Each record or row should end with a return character. Any blank lines become 
blank records or rows. 

To copy Word Processor information to the Database or Spreadsheet: 

1. In the Word .Processor, insert tab characters between text that you 
want 10 appear in separate fields or columns. 

Let's review the kinds of tabs that can be used and how they're 
created: 
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• Click on the Ruler for a left tab stop. 

• Press and hold the [Control] key and click on the Ruler for a Right 
tab stop. 

• Press and hold the [Shift] key and dick on the Ruler for a Center 
tab stop. 

• Press and hold [Shift] and [Control] together and click for a Decimal 
tab stop. 

2. Insert return characters to start new records or rows. 

3. In the Word Processor document, select the text that you want to 
copy. 

4. Choose Copy from the Edit menu. 

5. Activate the Database or Spreadsheet document. 

6. Activate the entry or cell in the upper-left corner of the area you want 
to paste into. Since the information fills fields and cells to the right, and 
records and rows downward, make sure that the records or cells in this 
area are blank. 

7. Choose Paste from the Edit menu, or use the keyboard equivalent, 
[Controll-V. AtariWorks pastes the copied information. 

Copying Database Information to the Spreadsheet 

When you copy Database information to the Spreadsheet, each entry 
becomes one cell in the Spreadsheet, each record becomes part 01 a row, and 
each field becomes part of a column. 

To copy information from the Database to the Spreadsheet: 

,. Select the information in a Database list window. You can select 
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individual or adjacent records , fields, or field entries. 

2. Choose Copy from the Edit menu. 

3. Activate the Spreadsheet window. 

4. Activate the cell in the upper-left comer of the area you want to paste 
into. Since the information fills cells to the right and rows downward, make 
sure that the cells in this area are blank or make new blank cells to 
accommodate the pasted information. If you want to copy over existing 
cells, you can. 

5. Choose Paste from the Edit menu. AtariWorks pastes the selected 
information into the Spreadsheet. 

Text becomes Spreadsheet labels, and numbers become Spreadsheet 
values. AtariWorks copies the field names as labels in one row, with each 
record in a separate row. The information is displayed in the existing cell format. 

Copying Spreadsheet Information to the Database 

When you copy Spreadsheet information to the Database, each 
Spreadsheet column becomes a database field . Each spreadsheet row or 
portion 01 a row you copy becomes a database record. II you paste a 
spreadsheet column below an existing field, or a spreadsheet row to the right of 
an existing record, the new and existing information combine to make one field 
or one record. 

In the Database, you'll need to set up enough fields to accommodate all 
the columns you're copying from the Spreadsheet. The columns that don't fit 
won't be pasted into the Database. 

To copy information from the Spreadsheet to the Database: 

1. Select the information in the Spreadsheet. You can select a single 
cell , a block of cells, or entire rows or columns. 

2. Choose Copy from the Edit menu. 
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3. Activate the Database window. 

4. Activate the entry in the upper-left corner of the area you want to 
paste into. 

5. Choose Paste from the Edit menu. AtariWorks pastes the selected 
cells into the database document. Each cell becomes a database entry. 

Adding Finishing Touches 

Once you've moved information from one tool to another, you can modify it 
as you would any information in that tool. Since the Word Processor gives you 
the most options for formatting, this section gives you some ideas on how you 
can enhance the appearance of information you've integrated in a Word 
Processor document. 

Formatting Text 

Here are some ideas for changing the appearance of the overall 
document: 

• Change the font, type size, or type style of the entire document or 
portions of it. 

• If you've copied a large amount of information, you may wish to 
repaginate by inserting manual page breaks. 

• Move the tab stops to adjust columnar tables. 

• Change the line spacing or indent certain pieces of information for 
emphasis. 

• Add headers and footers using the range of options available in the Word 
Processor. 

• Use the Draw command to add lines, boxes, or circles to separate and 
draw attention to important information. 
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Editing Pictures 

A picture can be a chart or table from the Spreadsheet, or lines and 
shapes from the Word Processor, or imported GEM Metafiles. When you add a 
picture to a Word Processing document, you can still work with it in the following 
ways: 

• Add text for titles and labels. 

• Add lines from the labels to the picture. 

• Draw additional lines or shapes with the Draw command. 

• Change the proportions to make the picture wider or taller. 

• Delete pictures. 

• Change the font face of the text in a GEM Metafile. 

For more information on using the Word Processor's drawing capability, 
see Formatting a Document in the Word Processor chapter. 

Selecting and Sizing a Picture 

Once you've copied a picture into a word processor document, you may 
find that it's not in the right place, it doesn't quite fit, or it would look better in a 
different size. In order to manipulate a picture in the Word Processor, you first 
must select it. After you've selected a picture, you can change its size, or copy, 
move, or delete it. 

To select a picture: 

1. Choose Select Picture from the Edit menu, or use the keyboard 
equivalent (CantroIJ-Z. The cursor must be on the same line as the picture. 

2. Click on or to the left of the picture. The entire picture is highlighted 
(reversed in color from the color of the main text area). The picture 
remains selected until you click elsewhere. 
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Remember, text that you type with the Word Processor is not part of a 
picture and can't be selected while a picture is selected. You can, however, 
select both text and a picture by choosing Select All , or using the keyboard 
equivalent (Control]-A. If you're not satisfied with the change, you can choose 
Undo from the Edit menu (or press the [Undo] key) and try again. 

To move a picture with Cut or Copy: 

1. Select the picture. 

2. Choose Cut or Copy from the Edit menu (or use keyboard 
equivalents), position the insertion point, and paste it at the new location. 

Adding and Removing Text with Pictures 

You can type text directly over a picture in a word processor document or 
in any area around it. You can add special labels to a graph, add a large title to 
a chart for a presentation, or call out special points using lines and text. 

To add text to a picture: 

1. Position the insertion point where you want to type on the picture. 
(Unless you want to begin typing at the left margin, you'll need to use the 
space bar or the [Tab] key to reach the location you want.) 

2. Start typing. 

Text that crosses a line or dark area of a picture may be difficult to read. 
Experiment with different type styles such as Outline until you get the desired 
effect. Text typed over a picture in the Word Processor is the same as text you 
type anywhere else. Standard AtariWorks editing commands work normally. 

To remove text from a picture: 

1. Select the text. 

2. Choose Cut or Clear from the Edit menu. 
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MERGING : 
CREATING MAILING LABELS, FORM LETTERS, AND FORMS 

The Word Processor and the Database work together to let you combine 
information from a Database document into a form you create in a Word 
Processor document. With this merge capability, you can create form letters. 
address mailing labels and envelopes, and print on preprinted continuous forms. 
By using the Word Processor's drawing and formatting capabilities, you can 
design an attractive fC?rm that AtariWorks fills out for you automatically. 

This section begins with an overview of the merge procedure, followed by 
several examples of how to use merging in your work. You'll learn how to: 

• Create a merge document using the Word Processor and Database 

• Print a series of customized documents 

• Create mailing labels 

• Create a form letter 

• Fill out forms--those you design yourself using the Word Processor and 
preprinted forms 

Creating a Merge Document 

A merge document looks like any other Word Processor document, except 
that it contains placeholders instead of regular text. A placeholder contains the 
name of a Database document and a field name. 

To create a merge document, you add information from a Database 
document to a Word Processor document. First, you indicate where you want 
information to go by inserting placeholders into your Word Processor document 
with the Begin Merge command. Then you use the Mail Merge command to 
print customized copies of the Word Processor document. 

For each entry in a Database field you specify, AtariWorks prints one Word 
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Processor document, replacing the placeholder with an entry from the specified 
field. Thus, each record in the Database document produces one customized 
Word Processor document. The general procedure for creating a merge 
document and printing the customized copies is summarized below. Specific 
examples follow on how to use merging to create mailing labels, form letters, 
and customized forms. The Database document must be a file that has been 
previously saved. 

To Create a Merge Document: 

1. Create a Database document with the information you need, or open 
an existing Database file. You can have more than one Database 
document open from which to merge. 

2. Create a new Word Processor document, or open an existing Word 
Processor file. 

3. In the Word Processor document, type any text that will remain the 
same for all the copies. 

4. Position the insertion point where you want to insert the first 
placeholder. 

5. Choose Begin Merge from the Edit menu. 

6. A dialog box opens with the active Database documents and fields 
listed; choose the Database document you want. 

7. AtariWorks will now list the fields from the selected database 
document. 

8. Choose the field you want to merge. AtariWorks inserts a place 
holder, containing the name of the Database document and the specified 
field name, at the insertion point in the Word Processor document. 

Note: AtariWorks does not wordwrap a placeholder to the next line if the 
placeholder will not fit. To check, choose Show Data from the Edit menu. 
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9. After you insert each placeholder, you can add any appropriate 
spacing or punctuation around it before inserting another. 

10. Repeat steps 4 through 9 for each piece of Database information you 
want to include in your Word Processor document. 

To View Merge Information 

Any time you want to view Database information as it will look in your 
finished document, choose Show Data from the Edit menu. 

AtariWorks displays information from the first record in the specified 
Database document if no record is selected, or from the currently selected 
record. You can change the information displayed by activating the Database 
document and selecting another record. When you activate the Word Processor 
document again, you will see information displayed from the newly selected 
record. 

Choose Show Data to see the placeholders again. If you close a specified 
Database document, or if you open the Word Processor merge document 
before you have opened a specified Database document, you'll see the 
message DATABASE NOT ON DESKTOP in the appropriate placeholder. You 
need to open the Database document in order to print or see information 
displayed from the records. If you delete a specified field or change a specified 
field name in a Database document, you'll see the message FIELD NOT IN 
DATABASE in the appropriate placeholder. 

To delete a placeholder: 

t. Select the placeholder as you would any text. 

2. Press the {Backspace} or{ Delete] key, or use the Cut or Clear 
command from the Edit menu. The placeholder disappears. 

To change the font or style of a placeholder 

1. Select the placeholder as you would any text. 
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2. Choose oommands from the Font or Style menu or use the 
appropriate Tool Bar icons. The information in the placeholder changes to 
reflect your choices. 

Printing Merge Documents 

You use the Print Merge oommand to print your merge documents. 

To prepare for printing: 

1. In the specified Database document(s) , sort the records to arrange 
them in the order you want them to print. 

2. If you want to print only a subset of the records in the Database, use 
the Record Selection or Match Records oommand from the Select 
menu to select the records you want to print. 

3. Activate the Word Processor merge document, and choose Page 
setup ... from the File menu and make any wanted changes. 

4. Set the Header/Footer strings if desired by choosing the 
Header/Footer ... command from the Edit menu. 

5. Prepare your printer for printing, adding any special forms or paper. 

To print your customized documents: 

1. Choose Print Merge ... from the File menu. You'll get the same 
dialog box as for normal printing. 

2. Click any appropriate options, then click the OK button. AtariWorks 
will beg in to print the customized documents. 

Note: If you choose Print instead of Print Merge .•• , AtariWorks prints one copy 
of the Word Processor merge document with the placeholders rather than the 
Database information. If you choose Show Field Data and then choose Print, 
AtariWorks prints one copy of the document with the data from the first record or 
the selected record. 
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Creating Mailing Labels 

To create mailing labels, you change options in the Page Setup ... dialog 
box to correspond to the measurements of your mailing label, then create a 
merge document in the Word Processor containing only placeholders. You can 
save the document to use whenever you want to print mailing labels. 

To change options with Page Setup: 

1. Create a new Word Processor document. 

2. Choose Page Setup ... from the File menu. 

3. If necessary, choose the paper size and margins appropriate to your 
label. 

4. Select Label Specifications. A dialog box appears showing 
different parameters needed for the label specifications. 

a. Set Enable Label Printing. 

b. Enter the number of labels in a row and a column on the paper. 

C. Select Print Grid if you want a grid to be printed around the labels. 

d. Select Show Label No. if you want label numbers to show in the 
grid on your screen. 

5. Click the OK button. 

A grid will appear on the screen showing the different labels as they will 
print. Except for the first label in the top left, all others are grayed out. The 
information contained in this box will be printed on each label with the 
information from the database(s) used. 

Next, you will need to set up the merge document. To review this 
procedure, see Creating a Merge Document earlier in this section. The steps 
to follow include: 
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1. Open the Database file you want to use for the mailing labels. 

2. Activate the Word Processor merge document and design your 
mailing label by choosing the font, type size, and type style you want from 
the Font and Style menus. 

3. Choose Begin Merge from the Edit menu to insert the placeholders. 
Arrange the placeholders as you normally would a name and address-­
usually with the name on the first line, street address on the second, and 
city, state, and zip on the third. 

To see how the actual information looks, and to adjust the alignment, if 
necessary, choose Show Field Data from the Edit menu. 

To print the 'abe's: 

1. Choose Print Merge •.• from the File menu. AtariWorks will display 
the regular Print dialog box. 

2. Click the OK button. 

You may need to experiment with label alignment. Test your alignment 
with a few records first. Adjust the horizontal alignment of the labels in the 
printer until you are satisfied. 

You can use this same method to create other label-like documents. Here 
are a few suggestions: 

• Address envelopes. 

• Print continuous index cards to catalog your tape or compact disc 
collection. 

• Print membership cards for a club. 

Creating a Form Letter 

A form letter contains some standard text, but also adds information 
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Specific to each recipient. Names and addresses are the most common types of 
information you would want to merge into a form tetter. But you can also create 
a Database document with specific phrases or sentences that apply to individual 
recipients. 

For example, if you sell bicycles to bike shops, you might want to thank 
each shop individually for its order, mentioning the amount the shop purchased. 

To set up a form letter, you create a merge document by typing all the text 
that will remain the same in each lener, and inserting placeholders for the 
information that will vary. If you need to review this procedure, follow the 
instructions in Creating a Merge Document earlier in this section. 

Creating and Filling Out Forms 

Nearly any office or business uses a variety of forms : 

• Expense reports 

• Address lists of customers, clients, friends, and contacts 

• Invoices and statements 

You can set up a form in the Word Processor as though you were 
preparing a document for an individual client. By merging with the Database, 
you can set it up once, and have AtariWorks fill it out whenever you need it. 
Your entire form can come from your Word Processor document, or you can 
design a layout that prints information on a preprinted continuous form. 

By creating your form in the Word Processor, you'll have flexibility with 
alignment, positioning, fonts, type sizes, type styles, and shapes and lines from 
the Draw feature . Use Page Setup". from the File menu and Draw Pattern ... 
from the Edit menu, or use drawing tools found on the Tool Bar. Use the type 
options available to you from the Style and Font menus or appropriate icons on 
Ihe Tool Bar. 
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To set up a form that you can later complete during a print merge: 

1 . Open or create the Database document that contains your 
information. 

2. Create a new Word Processor document and design your form. Type 
any standard text. 

3. When you are satisfied with your form, add placeholders and 
complete your merge document. 

Note: If you need to review this procedure, see Creating a Merge Document 
earlier in this section. 

Using Preprinted Forms 

If you decide to use preprinted continuous forms, measure one of the 
forms and include the measurements in the Page Setup ... dialog box. If you 
need to review this procedure, see Creating Mailing Labels earlier in this 
section. Using preprinted forms will take some experimentation to get precise 
alignment. But once the merge document is set up, you can save it and use it 
over and over again to print that form. 
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Appendix A 

SPREADSHEET FUNCTIONS 

AtariWorks has 53 built-in functions that you can paste or type into 
formulas. As explained in Chapter 5, a function is similar to an arithmetic 
operator, such as + or -, in that it produces a new value from other values, 
called arguments. This section describes all of the functions AtariWorks makes 
available in its Spreadsheet. It is divided into two parts: 

• A discussion of the arguments expected by AtariWorks functions . 

• A detailed listing of the available spreadsheet functions arranged by 
subject category, in alphabetical order. 

ARGUMENTS TO FUNCTIONS 

General 

A function can have no arguments or it can have one or more arguments. 
Arguments can be numbers, formulas, cell references,or range references. 
Arguments can also be other functions that relate to a number. 

An empty cell, or a cell containing text, is normally treated as 0 (zero) 
when used as an argument to a function . However, the functions Average, 
Count, Max, Min, StDev, Sum, and Var ignore such cells completely. 

In AtariWorks, all function arguments have a numeric value. In some 
cases, however, these values represent a logical value of either TRUE or 
FALSE. The first argument in the If function is an example. For such arguments, 
the number 0 (zero) represents the logical value FALSE, and all other numbers 
represent the logical value TRUE. Similarly, all functions in AtariWorks return 
numeric values as results. In some cases, however, these returned values 
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represent a logical value or enher TRUE or FALSE. The IsNA function is an 
example. As the result of such functions, the number 0 (zero) represents the 
logical value FALSE; and the number 1 represents the logical value TRUE. For 
example, IsNA(Al ) equals 1, where Al contains NlA, and IsNA(Al) equals 0 
where A 1 contains a label or a number, or it is blank. The And, Or, and Not 
functions are examples of these types of functions in that their arguments. as 
well as their results, are logical values represented by numbers. 

For example: 

Not(t) equals a 
And(-t ,2,4) equals t 
Not(2) equals a 
And(-t ,2,0) equals a 
Not(O) equals t 
Or(0,0,5) equals 1 

Notation Conventions 

In the function directory that follows, arguments are described with this 
notation: 

Value or number Refers to an argument that must be a number, cell 
reference, or formula, as in Min(2,3). Min(A 1 ,Bl ), or Min(3+A 1 ,Sqr1(4)) 

Range Refers to an argument that must be a range reference, such as 
B9:F9 

Values Refers to an argument that can be any of the above. 

To distinguish different arguments in a function , numbers are added to the 
standard notation, as in value-1, value-2, range-I, rang9-2, values-I, values-2, 
and so on. When there is a useful descriptive word for an argument, such as 
"rate" in a financial function, that word is used in place of the generic term 
"value." Sometimes, the standard notation is modified by another word , as in 
lookup-number or compare-range. 
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DIRECTORY OF FUNCTIONS 

The detailed directory of functions in this section is presented in 
alphabetical order grouped by subject category. Arguments to functions are 
provided in parentheses. 

Financial Functions 

FV( Rate, NPer , Pmt , PY , Type) 

The FV function gives the future value of an investment involving constant 
cash flows. A more complete description is provided below under Rate. If you 
omit either PVor type, their values are assumed to be O. 

Use the following cash flow convention: represent cash received with a 
positive number, cash paid out with a negative number. 

IRR( range, guess) 

The IRA function gives the internal rate of return of a series of cash flows, 
represented by the numbers in range. The IRR is the interest rate that gives the 
series of cash flows a net present value of O. 

AtariWorks uses an iterative technique to compute IRR, which can have 
more than one solution. If the successive results of IRR do not converge after 
20 iterations (repetitions), IRR gives the error value ·Error·. 

Range should be a reference that contains numbers. If range contains text 
or blank values, those values are ignored. 

Guess specifies the starting value of the iteration. If IRR does not 
converge. Try different values for guess. Usually, a starting value between 0 
and 1 will yield a meaningful result. 
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Example: 

If you have an investment represented by the cash flows ($5000), $t 000, 
$1500. $2000. ($3000). $2500. and $5000. which are entered in A 1 :A7. 
then: 

IRR (A1:A7. 10%) equals 15.05%. 

NPer( Rate. Pmt . PV • FV • Type) 

The NPer function gives the number of periods of an investment involving 
constant cash flow. A more complete description is provided below under Rate. 
If you omit FVor Type. their values are assumed to be O. 

NPV( Rate , values·1, values·2, ... ) 

The NPV function gives the net present value of a series of future cash 
flows, represented by the numbers in the list of values, discounted at a constant 
interest rate specified by Rate. 

The cash flows are assumed to occur at equal intervals, the first cash flow 
occurring at the end of the first interval. 

The list of values can contain one or more arguments. The values 
arguments should be numbers, or references that contain numbers. It a 
reference argument contains teX1 or blank values, those values are ignored. 

Pm1( Rate. Nper • PV . FV • Type ) 

The Pmt function gives the periodic payment of an investment involving 
constant cash flows. A more complete description is provided below under 
Rate. If you omit FVor Type, their values are assumed to be O. 

Use the following cash flow convention: represent cash received with a 
positive number, cash paid out with a negative number. 
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PV( Rate , ~Per , Pmt , FV , Type ) 

The PV function give the present value of an investment involving 
constant cash flows. A more complete description is provided below under 
Rate. If you omit FVor Type, their values are assumed to be O. 

Use the following cash flow convention: represent cash received with a 
positive number, cash paid out with a negative number. 

Rate( NPer , Pmt , PV , FV , Type. guess) 

The Rate function gives the interest rate per period on an investment 
involving cash flows. Rate is one of five standard parameters in cash flow 
problems involving constant payments. The other four functions already have 
been briefly described: FV (future vatue). NPer (number of periods) , Pmt 
(periodic payment), and PV (present value). The following discussion applies to 
all five functions when used together. 

Rate and Nper must refer to the same period or interval. For example, if 
Nper is the number of months, then Rate must reflect the effective monthly 
interest rate. 

Type indicates whether payments occur at the beginning or the end of the 
periods. If Type is 0, the first payment is assumed to occur at the end of the first 
period; if Type is I , the first payment occurs at the beginning of the period. If 
you omit Type from your function formula, it is assumed to be O. 

For the arguments PV, FV, and Pmt, use the following cash flow 
convention: cash received is represented by a positive number; cash paid out is 
represented by a negative number. The examples below illustrate this 
convention. 

AtariWorks uses an iterative technique to compute Rate, which can have 
zero, one, or two solutions. If the successive results of Rate do not converge 
after 20 iterations, Rate gives the error value "Error". 
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Guess specifies the starting value of the iteration. If you omit guess, it is 
assumed to be 0.1 or 10%. If Rate does not converge, try different values for 
guess. Usually, a starting value between 0 and I will yield a meaningful resu~. 

All of the arguments must be numbers. In PV, FV, NPer, and Pmt, you 
can omit the last two arguments, which will be assumed to be O. In Rate, you 
can omit the Jast three arguments, which will be assumed to be 0, except for 
guess, as noted above. 

AtariWorks uses the following equations to solve for one financial 
argument in terms of the others: 

PV' (1+Rate) • NPer + Pmt • (1 + Rate' Type) (/ + Rate) 
~NPer·1 +FV;O 
(for Rate <> 0) 

PV + Pmt ~ NPer+ FV= 0 
(for Rate = 0) 

Examples: 

(1) You have received a loan of $15,000 at an interest rate of 9% (monthly 
rate of 0.75%), and you must pay it off in 18 months, paid at the end of 
each month. PV is 15000, Rate is 0.75%, NPer is 18, and FV and Type 
are O. The monthly payment is calculated by the following formula: 

Pmt( 0.0075,18,15000) 

(2) A limited partnership plans to buy a commercial strip for $1 ,850,000 
with expectation of selling the property for $2,250,000 in 6 years. The rent 
for the commercial units amounts to $475,000 annually. PV is ·1850000, 
FV is 2250000, NPer is 6, Pmt is 475000, and Type is O. The numbers 
$475,000; $1 ,850,000;and $2,250,000 are entered in cells At, 82, and 
C3. If your guess at the annual rate of return is 10010, the actual annual 
rate of return is calculated using the following formula: 

Rate( 6 , A 1-82 , C3 , 0 , 0, 0.1 ). 
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(3) You presently have $3,200 in your savings account earning 6% annual 
interest (0.5% monthly interest, or 0.005 as Rate), and you plan to deposit 
$200 at the beginning of every month for the next 24 months. PV is 3200, 
Rate is 0.005, Pmt is -200, NPer is 24, and Type is 1. The amount of 
money your savings account will accumulate by the end of 24 months is 
calculated with the following formula : 

FV( 0.005, 24, 200, 3200 , 1). 

Logical Functions 

And( values- l • values-2 ... ) 

The And function gives the value 1 (TRUE) if all the values in the list of 
arguments are non-zero (TRUE). If any of the values is 0 (FALSE). it gives the 
value 0 (FALSE). 

If a reference argument contains text or blank values, those values are 
ignored. 

Examples: 

And(2+2:4,2+3=5) equals 1 
And(2+2=5,2+3=5) equals 0 

Choose( index . number-I, number-2 ... ) 

The Choose function uses index to select a value from the following 
arguments in the list. If index is 1. Choose gives number-1; if index is 2, 
Choose gives number-2; and so on. 

If index is less than 1 or greater than the number of the last value in the 
list, Choose gives the error value -Error- . 
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Examples: 

Choose( 2 , 10 , 20 , 30 , 40 ) equals 20 

If cells are used to indicate values, the above function would read like Ihis: 

Choose( A3 , 87 , C7 , 0 7 , E7 ) equals 87 

False( ) 

The False function takes no arguments and returns the value 0 (FALSE). 

Example: 

Choose( 2 , False( ) , True( ) , True( ) , False( ) , True( ) ) equals 1 

If( number , number-if true , number-if-false ) 

The If function gives number-it-true if number is non-zero (TRUE). and 
number-it-false if number is a (FALSE). 

Example: 

Given that A5 contains the number 98, and B1 0 contains the number 90: 
II( Or( A5<80 , 8 10<75 ) , 1 ,0 ) equals 0 

IsBlank( values-1 , values-2 ... ) 

The IsBlank function can have any number of arguments . All arguments 
must be cell references. IsBlank gives the value 1 (TRUE) if all cell references 
in the list of arguments are blank or contain text. Otherwise, it gives the value a 
(FALSE). 
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IsError{ value) 

The IsError function gives the value 1 (TRUE) jf value is the error value 
*Error· . Otherwise, it gives the value 0 (FALSE). 

If you want to see if a range of cells contains any · Error· values, use the 
Sum function to sum the range. If any cells contain *Error· , the result of the 
Sum function will be "Error· . 

Example: 

Given that Al contains the formula"" 3/0: 
If( IsError( A 1 ). 0 • 1 ) equals 0 

IsNA( value ) 

The IsNa function gives the value 1 (TRUE) if value is the error value N/A. 
Otherwise, it gives the value 0 (FALSE). 

Example: 

Given that Al contains the formula"" NA( ): 
If( IsNA( Al ). 0 . 1) equals 0 

Not( number ) 

The Not function gives the value 0 (FALSE) if number is non-zero 
(TRUE). and gives 1 (TRUE) if number is 0 (FALSE). 

Examples: 

Not( 1+ 1 "" 2 ) equals 0 
NOI( 1+ 1 .3 ) equals 1 
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Or{ values·' , values-2 ... ) 

The Or function gives the value 1 (TRUE) if any of the values in the list of 
arguments is non-zero (TRUE) . If all of the values are 0 (False), it gives the 
value 0 (FALSE). 

If a reference argument contains text or blank values, those values are 
Ignored. 

Examples: 

Or( 1+1 ,",2.2+2 _ 5) equals 1 
Orr 1+1 .3.2+2.5) equals 0 

True( ) 

The True function takes no arguments and gives the value 1 (TRUE). 

Example: 

Chooser 2 . False( ) • True( ) • False( ) • True( ) ) equals 1 

Mathematical Functions 

Abs( number) 

The Abs function gives the absolute value of number. 

Examples: 

Abs( 2 ) equals 2 
Abs( -2 ) equals 2 
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Exp( number ) 

The Exp function gives e raised to the power of number. The 
mathematical constant 8 is 2.7182818 ... , the base of the natural logarithm. 

This function is the inverse of the Ln function (natural logarithm). 
To calculate powers of other bases, use the exponentiation operator (") . 

Examples: 

Exp( 1 ) equals 2.7182818 (the value of the nalural base, e) 
Exp( Ln(3) ) equals 3 

Int ( number ) 

The Int function gives the largest integer less than or equal to number. 

Examples: 

Int( 8.9 ) equals 8 
Int( -8.9 ) equals -9 

Ln( number ) 

The Ln function calculates the natural logarithm of number. 

Natural logarithms use the mathematical constant e, 2.7182818 .. , as a 
base. 

Number must be positive. 

Ln is the inverse of the Exp function, e raised to the power number. 

Examples: 

Ln( 2.7182818 ) equals 1 
Ln( Exp( 3 )) equals 3 
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Ln( 8 ) 1 Ln( 2 ) equals 3 (the base 2 logarithm of 8) 

Log10( number ) 

The Log 10 function gives the base 10 logarithm of number. 

Number must be positive. 

Log10 is the inverse of base 10 exponentiation. 

Examples: 

Log10( 10) equals 1 
Log10( 1 E5 ) equals 5 
Log 1 O( 10' 5 ) equals 5 
Log10( 8) 1 Log10( 2 ) equals 3 (the base 2 logarithm of 8) 

Mod( number, divisor·number ) 

The Mod function give the remainder (modulus) after number is divided by 
divisor-number. The result has the same sign as divisor-number. 

Pi t ) 

If divisor-number is 0, Mod gives the error value *Error". 

Examples: 

Mod( 3 • 2 ) equals Mod( -3 • 2 ) equals 1 
Mod( 3 • -2 ) equals Mod( -3 • -2 ) equals -1 
Mod( 7 • 4) equals 7-lnt( 7 14 )"4 equals 3 

The Pi function takes no argument and gives the number 3.1459 ... , an 
approximation of the mathematical constant . 
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Example: 

ATan( 1 ) . 180 I Pill equals 45 (degrees) 

Rand( ) 

The Rand function gives a random number in the range a to 0.999 .... It 
generates a new random number every time the spreadsheet document is 
recalculated. 

Round( number , number-ol-digits ) 

The Round function gives number rounded to number-ot-digits. If number­
at-digits is positive, number is rounded to that many decimal places. If number­
at-digits is 0, number is rounded to the nearest integer. If number-ot-digits is 
negative, number is rounded to the left of the decimal point. 

Examples: 

Round( 2 . 15 , 1 ) equals 2.2 
Round( 2 . 149 , 1 ) equals 2.1 
Round( -1 . 475 , 2 ) equals -1 .48 
Round( 891 , -2 ) equals 900 

Slgn( number ) 

The Sign function gives 1 il number is positive, ° if number is 0, and -1 if 
number is negative. 

Examples: 

Sign( 7 + 3 ) equals 1 
Sign( 4 - 4 ) equals 0 
Sign( 3 - 7 ) equals -1 
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Sqrt( number) 

The Sqrt function gives the positive square root of number, 

Number must be greater than or equal to O. If number is negative, Sqrt 
gives the error value ·Error·. 

Special-Purpose Functions 

Error( ) 

The Error function takes no arguments and retu rns the value -Error·, 

Example: 

Given that Al contains the formula - Error(): 
If(lsErrar( A1 ).0 . 1) equals 0 

HLookup( lookup-number, compare-range I index-number ) 

The HLookup function searches the first row of compare-range for the 
largest value that is less than or equal to lookup-number. Having found that 
value in some column of the first row, HLookup moves up or down in that 
column by an amount specified by index-number and gives the value found 
there. (fndex-numbercan be any number; non-integers are rounded). 

If index-number is 1, HLookup gives the value from the current row. 
If index-numooris 2, Hlookup gives the value from the row below. 
If index-number is 0, Hlookup gives the value in the row above the 

current row. 
If index-number is -1 , Hlookup gives the value in the row that is two rows 

above the current row. 
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The values in the first row of compare-range must be in ascending order. 
If lookup-number is smaller than the smallest value in the first row of compare­
range, HLookup gives the error value ·Error· . 

Example: 

If At :E1 contains the values 10000, 20000, 30000, 40000, and 50000, 
and A5:E5 contains the values .01, .02, .03, .04, and .05, then: 

HLookup( 35000 , Al :E 1 , 5 ) equals .03 
HLookup( 35000 , Al :E , 1 ) equals 30000 
HLookup( 5000 , At :E1 , 5 ) equals *Error· 
HLookup( .035 , A5:E5 , -3 ) equals 30000 

Index( range, row , column ) 

The Index function gives the content of the indexed cell , selected by the 
indices row and column, start ing from the cell in the upper-left corner of range. 

Examples: 

Index( 82:04 , 2 , 3 ) equals the value of 03 
Index( 82:02 , 1 , 2 ) equals the value of C2 
Index( 82:84 , 2 , 1 ) equals the value of 83 
Index( 82:02 , 0 ,0) equals the value of A 1 
Index( C4:D4, -I , -1) equals lhe value of A2 

If A1 :A5 contains the numbers 10, 7, 9, 27, and 2, then: 

Index( A1:A5 , 3 , 1 ) 13 equals 3 

Lookup( lookup-number , compare-range, result-range ) 

The Lookup function searches compare-range for the largest value that is 
less than or equal to lookup-number. Lookup gives the corresponding value in 
result-range. 
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The values in compare-range must be in ascending order. If lookup­
number is smaller than the smallest value in compare-range, Lookup gives the 
error value ·Error·. Compare-range and result-range should have the same 
length. Each of these range arguments must be one-dimensional, but they need 
not both be in the same direction. 

Examples: 

If A 1 :E1 contains the oomparison values 10000, 20000, 30000,40000, and 
50000, and A4:E4 contains the values 10, 20, 30, 40,and 50, then: 

Lookup( 35000 , Al :El , A4:E4 ) equals 30 
Lookup( 5000 , A 1 :El , A4:E4) equals ·Error· 
Lookup( 35000 , Al:El , Al :El ) equals 30000 

Match( lookup-number , compare-range , type ) 

The Match function gives the number of the comparison value in 
compare-range that matches lookup-number. If lookup-number matches the first 
comparison value, Match gives 1. If lookup-number matches the second 
comparison value, Match gives 2, and so on. If lookup-number does not match 
any of the comparison values, Match gives the error value ·Error· . If compare­
range contains multiple rows, Match searches from leh to right. one row al a 
time; that is, it first searches the first row, then the second row, and so on. 

The rules for matching the values are determined by type: 

If type is 1, lookup-number matches the largest comparison value that is 
less than or equal to lookup-number. If lookup-number is less than the smallest 
comparison value, then it does not match any of them. The comparison values 
should be in ascendir.g order. 

If type is -1 , lookup-number matches the smallest comparison value that is 
greater than or equal to lookup-number. If lookup-number is greater than the 
largest comparison value, it does not match any of them. The comparison 
values should be in descending order. 
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If type is 0, lookup-number matches the first comparison value that is 
equal to looku,rnumber. If lookup-number is not equal to any of the comparison 
values, then it does not match any of them. The comparison values can be in 
any order. 

NA() 

Examples: 

If A 1 :A5 contains the numbers 60, 70, 80, 90, and 1 DO, then: 
Malch( 75 • A I:A:; • I ) equals 2 
Match( 55, A1:A5, 1 ) equals -Error-
If A 1 :AS contains the numbers 100, 90, 80, 70 ancl60, then: 
Malch( 75. AI :A5. ·1 ) equals 3 
Malch( 105 • AI :A5 • ·1 ) equals 'Error' 

If A 1 :C3 contains the numbers: 
10 20 30 
40 50 60 
70 80 90 then: 
Malch( 40 • AI :C3 • 0 ) equals 4 

The NA functions gives the error value NlA. 

Example: 

Given that A 1 contains the formula - NA ( ): 
If( NA( Al ). O . 1 ) equals 0 

Type( value ) 

The Type function gives the type of value. If value is a cell reference and 
the cell referenced is blank or contains text, Type gives 2. Otherwise, Type 
gives 1 when value is a number, 8 when value is the error value N/A, and 16 
when value is the error value ·Error·, 
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Examples: 

If A1 contains the text 'Smith', then : 
Type( A 1 ) equals 2 
Type( 5 ) equals 1 
Type( 1 10 ) equals 16 

VLookup( lookup-number, compare-range, index-number ) 

The VLookup function is identical to HLookup except that it searches the 
first column (rather than row) of compare-range, and moves left or right in that 
row by an amount specified by index-number. 

Statistical Functions 

Average( values-1 , values-2.:.) 

The Average function gives the average of the numbers in the list of 
arguments. The arguments should be numbers or references that contain 
numbers. If a reference argument contains text or blank values, those values 
are ignored. 

Examples: 

If A 1 :A5 contains the numbers 10, 7, 9, 27, and 2, then: 
Average( AI :A5 ) equals 11 
Average( A 1 :A5 , 5 } equals to 
Average( A 1 :A5 ) equals Sum( A1:A5 ) I Coun1( A 1 :A5 ) 

Count( values-l , values-2 ... ) 

The Count function gives the count of the numbers in the list of 
arguments. The arguments should be numbers or references that contain 
numbers. If a reference argument contains text or blank values, those values 
are ignored. 
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Examples: 

If A 1 :A5 contains the numbers 10, 7, 9, 27, and 2, then: 
Count( AI :A5 ) equals 5. Count( A 1 :A5 , 5 ) equals 6. 

The Max function gives the largest number in the list of arguments. The 
arguments should be numbers or references that contain numbers. If a 
reference argument contains text or blank values, those values are ignored. 

Examples: 

If Al :A5 contains the numbers 10, 7, 9, 27, and 2, then: 
Max( A 1 :AS ) equals 27 
Max( AI :A5 , 30 ) equals 30 

The Min function gives the smallest number in the list of arguments. The 
arguments should be numbers or references that contain numbers. If a 
reference argument contains text or blank values, those values are ignored. 

Examples: 

If A 1 :A5 contains the numbers 10, 7, 9, 27, and 2, then: 
Min( AI :A5 ) equals 2 
Min( AI :A5 , a ) equals a 

StDev( values-1 , values-2 ... ) 

The StDev function gives the sample standard deviation of the numbers in 
the list of arguments. The arguments should be numbers or references that 
contain numbers. If a reference argument contains text or blank values, those 
values are ignored. 
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The formula used is: Sqrt( Var( values-l , values-2, ... )) 

The sample standard deviation is the best estimate of the population 
standard deviation based in a sample of the population. If your sample 
represents the entire population, you can compute the true population standard 
deviation by including the average of the sample in the list of arguments to 
StDev: 

StDev( Population, Average( Population )) 

Examples: 

If A I :A5 contains the numbers 10, 7, 9, 27, and 2, then: 
StDev( At :A5 ) equats 9.460 
StDev( At :A5 , Average( At :A5 )) equals 8.462 

Sum( values-I , values-2 ... ) 

The Sum function gives the sum of the numbers in the list of arguments. 
The arguments should be numbers or references that contain numbers. If a 
reference argument contains text or blank values, those values are ignored. 

Examples: 

If AI :A5 contains the numbers 10, 7, 9, 27, and 2, then: 
Sum( At :A5 ) equals 55 
Sum( At :A5 , 5 ) equals 60 

Var( values-I , values-2 ... ) 

The Var function gives the sample variance of the numbers in the list of 
arguments. The arguments should be numbers or references that contain 
numbers. If a reference argument contains text or blank values, those values 
are ignored. 

The formula used is: (n"(x2) - (x)2) I (n " (n-t)) . 
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The sample variance is the best estimate of the population variance based 
on a sample of the population. If your sample represents the entire population, 
you can compute the true population variance by including the average of the 
sample in the list of arguments to Var, 

Var( Population, Average( Population )) 

Examples: 

If At :A5 contains the numbers 10, 7, 9, 27 and 2, then: 
Varl A 1 :A5 ) equals 89.5 
Var( A I :A5, Average( A I :A5 )) equals 71 .6 

Trigonometric Functions 

ACos( number ) 

The Acos function gives the arccosine of number. The arccosine is the 
angle in radians whose cosine is number. Number must be in the range ·1 to 1. 
The angle will be in the range 0 to 

Examples: 

Acosl -0.5 ) equals 2.094 12 13 radians) 
Acosl -0.5)' 180 I Pi() equals 120 (degrees) 

ASin( number ) 

Ther ASin function gives the arcsine of number. The arcsine is the angle 
in radians whose sine is number. Number must be in the range ·1 to 1. The 
angle will be in the range -( )/2 to ( )/2. 

Examples: 

ASin( -0.5 ) equals -0.524 I-I )/6 radians) 
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ASin( -0.5)' 180 I Pi() equals -30 (degrees) 

ATan( number ) 

The ATan function gives the arctangent of number. The arctangent is the 
angle in radians whose tangent is number. The angle will be in the range - ( )/2 
to ( )12. 

Examples: 

ATan( 1 ) equals 0.785 ( 14 radians) 
ATan( 1 ) . 180 I Pi() equals 45 (degrees) 

ATan2( x-number , y-number ) 

The ATan2 function gives the arctangent of x-number and y-number. The 
arctangent is the angle in radians determined by the point whose x and y 
coordinates are x-number and y-number. The angle will be in the range - to 
excluding . If both x-number and y-number are 0, Atan2 gives the value O. 

Examples: 

ATan2( t , t ) equals 0.785 ( 14 radians) 
ATan2( -1 , -t ) equals -2.356 (-3 14 radians) 
ATan2( -1 , -1 ) • t80 I Pi() equals - 135 (degrees) 

Cos( number ) 

The Cos function gives the cosine of number, where number is an angle 
in radians. 

Examples: 

Cos( 1.047) equals 0.5 
Cos( 60 • Pi( ) 1180) equals 0.5 
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Degrees( number ) 

The Degrees function converts an angle in radians to degrees. 

Example: 

Degrees( Pi( )) equals 1 80 

Radians( number) 

The Radians function converts an angle in degrees to radians. 

Example: 

Radians( 180 ) equals 3.14159 ... (lhe value of ). 

51n( number ) 

The Sin function gives the sine of number, where number is an angle in 
radians. 

Examples: 

Sin( a ) equals 0 
Sin( Pi( ) 1 2 ) equals 1 
Sin( 3· Pi ( ) 12 ) equals -1 

T8n( number ) 

The Tan function gives the tangent of number, where number is an angle 
in radians. 

Examples: 

Tan( 0.785 ) equals 0.990; Tan( 45 • Pi( ) 1 180 equals 1 
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